Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Extensions won't enable

Hello, I am fairly new to vanilla. I was trying to get the feed reader extension to work and it wouldn't. I can get it to show up on the extension mananger, however, whenever I hit 'enable extension' it merely refreshes the page. Now I cannot enable any other extensions either. I can disable extensions, but I cannot re-enable them. Anyone know what the problem could be? Thanks. jeremy www.cor13.com

Comments

  • Options
    lechlech Chicagoland
    Have you given the /appg/extensions,php the appropriate read/write permission? ie: chmod 666 /appg/extensions.php That's the likely culprit of it not saving your requests. same should go for your language and settings file.
  • Options
    Yep, They are all already set to 666. My extensions were working fine and then I tried to install the RSS Feed extension and they started malfunctioning. I am not sure if that is a coincidence or I possibly installed it wrong. Thanks for your help. -jeremy
  • Options
    MarkMark Vanilla Staff
    What version of the forum are you using? Which extension did you actually attempt to install (link, please)? Is your forum malfunctioning in any other way?
  • Options
    i am using .9.2.6 I was trying to use feed reader v1.0 (http://nick_e.cjb.cc/misc/FeedReader.php.txt) No, this is the only thing that has happened. thanks, -jeremy
  • Options
    MarkMark Vanilla Staff
    Hmmm. That is an odd one. The fact that the extensions.php file isn't allowing you to change anything and isn't throwing any errors is really really wierd. You can always manually edit the appg/extensions.php file to link to whatever extensions you want turned on. I'd take a look at that file just to be sure that the permissions on it are still correct. I'd see what is actually in that file and maybe even cut out the feedreader extension from it (if it's there) and try to use the form again. That file should just contain a list of includes to various extensions. So, to disable one of them, you'd just cut that include out of the file and save it.
  • Options
    Wow, that's a weird one... Did you change the url strings in the extension and upload MagpieRSS? Was that the only extension which caused such behaivor?
  • Options
    OK, I went in and manually added FeedReader and it showed up as working. However, I did not have all the files uploaded for magpie, and it displayed "Feed Reader error: magpie not installed" in the side panel. So I fixed the magpie problem and now there is nothing in the side panel. SirNot, what strings are you referring to? I am not sure if the extension caused the behavior, but it started acting that way soon after I tried installing the extension. Thanks for the help. -jeremy
  • Options
    The strings I'm referring to are the urls the extension is supposed to read from, you can find them at line 17 or so. I couldn't really be bothered creating a whole administration panel (partly because it was for 0.9.2, where each extension occupies just a file, not a folder), so you're going to have to get your hands a little dirty and configure it manually.
  • Options
    Hello, I have the same problem in two sites using 0.9.2.6. I had to manually edit appg/extensions.php to enable the extensions. This was working ok until I moved my sites from one server to other, but everything else in the forums is working ok. Any ideas?
  • Options
    lechlech Chicagoland
    restoring permissions on files that need to be written to (ie: chmod 0666) didn't work?
This discussion has been closed.