Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Can't change certain files

ShaSha
edited July 2006 in Vanilla 1.0 Help
I've been looking for a simple board to use for comments for my site & this was the perfect one. I already set everything up & everything works, except I can't change some files. For example, I downloaded the friendly URLs add-on & uploaded it, but when I went to that one line to settings.php, I went back to that file & saw that it didn't save. I also tried changing the permissions on some files & they stayed the same.

Comments

  • Options
    MarkMark Vanilla Staff
    Don't you get any errors when you try to save the file?
  • Options
    Nope. It's like I never touched it.
  • Options
    hey sha, on my host too it wont let you write over the top of it. The only way i could do anything to settings.php is by going to cpanel, then to file manager. Veiw settings.php copy it into a temp file delete it on the filemanager in cpanel. Then you edit it on your computer. Save it to the same name and upload it through ftp and chmod it. Takes a while but for some reason it wouldnt let me either.
  • Options
    MarkMark Vanilla Staff
    I bet this happens because the file is created by apache during the install.
  • Options
    I bet that's what it is. I'm able to change the permissions on the folders, but nothing else, yet everything still works. Looks like I'll have to do it that way, Immersion!
  • Options
    yeah it is due to it being created however on other apps this does not happen. Maybe you could research how other people do it Mark?
  • Options
    Okay, I tried to do it that way & it worked. Another question: does one have to use the #item part when linking to a discussion elsewhere?
  • Options
    nope, item is to determine where you where in the discussion. You may also disable in the forum in account options by selecting " Jump to the last read comment when clicking on discussion topic" option.
  • Options
    Thanks!
  • Options
    your welcome :P
This discussion has been closed.