Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Some Users Can't Login to Vanilla

edited November 2006 in Vanilla 1.0 Help
I'm brand new to vanilla but currently have about 8 users on my forum... some of them can login no problem, others haven't been able to login from day 1 (although they WERE able to setup an acct). According to the ppl having problems, they type in their un and pw, and vanilla acts like it's going to let them login, but then it goes back to the discussion page and it still says "You are not logged in (Sign In)" in the upper right hand corner.

I have even setup a un and pw, tested it by logging in AND posting and then gave the info to the user having trouble, and he said it won't work either.

I tried using Internet Explorer as a test (b/c I use FIrefox), but IE worked fine for me too..

Anybody have any ideas? Please help. Thanks in advance!

Comments

  • Guessing it's to do with their browsers session/cookie management. Check they allow cookies and are using the remember me box.
  • Yep, i think that worked... at least I was able to perfectly simulate the problem they were having by telling my browser NOT to allow cookies. I can't believe that three out of 8 users have their browsers set to deny cookies from my site... seems random and some poor design (i'll blame microsoft)
  • Also, make sure that you have your cookie domain set properly.

    I.E. if you have www.yoursite.com set as the cookie domain, then logins will break if your users try accessing by http://yoursite.com.

    The cookie domain should be set to .yoursite.com in the application settings. This should allow for cookies to work for both the www and non www versions of the site. (disclaimer: AFAIK from reading similar topics)
This discussion has been closed.