Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

FCKeditor toolbar doesn't appear

Hi all, I'm a Vanilla newbie, just setting up my first forum. I'm trying to get the FCKEditor extension running in Vanilla 1.03. I do not have any other extensions installed (yet). I've downloaded the FCKeditor extension package, and version 2.4 of the editor code per the readme. I've placed the FCKeditor directory under /vanilla-directory/extensions, and the downloaded FCKeditor code under /vanilla-directory/js. I have not moved the video directory 'cause I don't want video support. When I browse to Settings/Extensions in Vanilla, FCKeditor 2.1 is listed (I guess 2.1 is the extension version, I've installed version 2.4 of the editor code). I can click on the checkbox to enable FCKeditor, and the background of the extension description box changes, so it appears FCKeditor is enabled. However, when I add a comment to a discussion, the toolbar does not appear. I've been over the readme file several times, and don't think I missed anything. Can someone suggest why I'm not seeing the toolbar? TIA!

Comments

  • Options
    edited February 2007
    give me ur forum url and a test account
  • Options
    I have the same problem ... any solutions ?
  • Options
    Me too
  • Options
    edited June 2007
    I cannot get this extension working either.
  • Options
    I've opted for BBCodeParser and BBInsertBar... the oldest system for text format.
    Simple, fast and stable ^^ ...Lussumo philosophy
  • Options
    Yeah, I suppose... but adding youtube/google vids still isn't straight-forward enough for my users with the BBInsertBar method.
  • Options
    I am also having this issue after updating to the lastest version of FCKeditor. If I can find an old copy I'll probably try to roll back later today.
  • Options
    Ah, it turned out that the Visual Editor preference was not staying selected after navigating away from the Forum Preferences page. I used the GlobalPrefs option to set it and now it appears to be working fine.
  • Options
    Ah! This vital piece of information is missing completely from the readme file. As it is, I've found the readme a little confusing, but this should definitely be in there somewhere...

    Make sure to check the "Enable Visual Editing toolbar" option found in your Account Preferences (/account.php?PostBackAction=Functionality) section. If you want to set it for everyone, install and use the Global Preference Setting extension.
  • Options
    yep, itz on now :)
  • Options
    If you're hosted on a linux server, be sure the folder you put in the js folder is named FCKeditor and not fckeditor. FCKeditor worked perfectly on my local Windows server, but I had to change that in order to make it appear on my live site.

    And by the way, this discussion should be closed. You guys should use the addon related discussion.
This discussion has been closed.