Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

ČĆŽÄ?Å Ä?ćžđš

edited April 2007 in Vanilla 1.0 Help
ČĆŽÄ?Å Ä?ćžđš

utf-8 testing

Comments

  • As you can all see, it would be a great idea to add proper utf-8 support to Vanilla.
  • cmaciascmacias New
    edited March 2005
    ČĆŽĐŠčćžđš Are you sure ? 8¬)
  • > Are you sure ? 8¬)

    I don't know what you mean with that. Yes, I'm sure.
  • It's a joke ! (se dice así ?) I don't know what it means "ČĆŽĐŠčćžđš". Do you understand ? it is not my intention to bother (No es mi intención molestar)
  • edited March 2005
    Oh, that are just some Croatian characters, it doesn't have any meaning, it's purpose is to test utf-8.

    But, encoding sent-out by the server is ISO-8859-1, and there is no support to utf-8.
  • In Spain, there is a Refrain that says "Nunca te acostarás sin saber una cosa más"
    "You never go to bed, without know a new thing" ;)
  • MarkMark Vanilla Staff
    I hate these encoding issues. I'm open to suggestions from anyone that has one. Maybe a function for encoding/decoding from form submit, to saving to database, to displaying on screen.

    Keeping in mind that html entered in discussion titles should be encoded.
  • Well, I didn't post any HTML in title, that are just Croatian characters.

    The solution is right in your hands. Just make sure that both input and output is set in utf-8 and you're done. Also, that character encoding is properly set by server:

    `AddType text/html;charset=utf-8 .php`

    or this, so that everything is in utf-8:

    `AddDefaultCharset utf-8`

    But I'm not sure is the last example correct, I know it goes something like that...
  • MarkMark Vanilla Staff
    Oh, I see what you're saying.
    I was hoping to do something within php itself so that someone who wants to use vanilla, but has no control over their server settings, can get the proper encoding.
  • edited March 2005
    Well of course, even better then!

    Use this for that:

    <?php
    header('content-type:text/html;charset=utf-8');
    ?>

    IIRC.
  • MarkMark Vanilla Staff
    There ya go, thanks a lot for the help :)
  • BORKED!!!!
  • > BORKED!!!!

    Yes, maybe, because before encoding was iso. I will open new thread with the same characters to properly test it.
  • cool :) the oldest discussion on this forum, and it was made on my 25th birthday :D
  • wow cool, the was the first one?
This discussion has been closed.