Please upgrade here. These earlier versions are no longer being updated and have security issues.

Twitter issue : SSL is required

Hello everybody,

I installed Vanilla 2.1b1 on my server (1and1) and I've tried to get Twitter working properly since. I still get the message "SSL is required" when I try to register using Twitter. The URL of my forums is : http://www.playmag.fr/forums
My consumer key and consumer secret are correctly entered in the admin.

Any idea of what the problem is ?

Thanks in advance.

Comments

  • hgtonighthgtonight ∞ · New Moderator

    The API calls need to be made over https, IIRC.

    You can find more info here: http://vanillaforums.org/discussion/comment/202904/#Comment_202904

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Problem solve. Thanks a lot!

    hgtonight
  • Hi There,

    Kind of a newb here, so sorry if I am missing something.

    I was having the same of ["SSL required"] for the twitter same twitter login issue as the OP. I have folllowed the link to the link and corrected code by hgtonight, but the class.twitter.plugin.php seems to have changed, as my version not the same as the linked code.

    I have installed vanilla version 2.0.18.10. Here my pligininfo array, which is not compatible with the fix linked to. Am I missing something here?

    // Define the plugin:
    $PluginInfo['Twitter'] = array(
            'Name' => 'Twitter',
       'Description' => 'This plugin integrates Twitter with Vanilla. <b>You must r$
       'Version' => '0.1a',
       'RequiredApplications' => array('Vanilla' => '2.0.12a'),
       'RequiredTheme' => FALSE,
       'RequiredPlugins' => FALSE,
            'MobileFriendly' => TRUE,
       'SettingsUrl' => '/dashboard/settings/twitter',
       'SettingsPermission' => 'Garden.Settings.Manage',
       'HasLocale' => TRUE,
       'RegisterPermissions' => FALSE,
       'Author' => "Todd Burry",
       'AuthorEmail' => '[email protected]',
       'AuthorUrl' => 'http://www.vanillaforums.org/profile/todd'
    );
    
  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff
    edited April 2014

    @mbjvfx the issue is Twitter made is so all calls to the api need to go to https. So just do a CTRL+F in the file and make sure all links to Twitter that show HTTP, now show HTTPS

    find
    public static $BaseApiUrl = 'http://api.twitter.com/1.1/';
    to
    public static $BaseApiUrl = 'https://api.twitter.com/1.1/';

    find
    $Url = "http://api.twitter.com/oauth/authenticate?oauth_token={$Data['oauth_token']}";
    to
    $Url = "https://api.twitter.com/oauth/authenticate?oauth_token={$Data['oauth_token']}";

    Sharing is caring

    hgtonightmbjvfxUnderDogsafecamera23
  • Thanks Adrian Will do

  • Fixed my issue too.

Sign In or Register to comment.