Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Vanilla 2.3 fully supports PHP 7. Get it now!
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

login redirects to discussions index but does not log me in

edited October 2006 in Vanilla 1.0 Help
I've been having this problem since I installed it. Sometimes I have to go through sign in like 10 times to get it to finally sign me in. I searched through the forum but didn't find anything on this, sorry if I inadvertently double posted.



  • Make sure the domain you're accessing the login page from is the same as the cookie domain (eg. if the cookie domain is, access it via and not something like localhost).
  • well the domain is my regular domain and i'm only accessing it through that domain so I don't think that is it...

    here is a link to my installation in case anyone wants to see if they can recreate it.

    login: demo
    pass: pass
  • That is weird. It only seems to work when I check the 'remember me' button. Maybe something screwed up with your server's session handling?
  • yeah, i dunno... it's an IIS server, dunno if that makes a difference. I have like a half dozen apps running on there that use sessions with no problems though
  • I must be a session problem. Check the error log and your session settings.
  • edited October 2006
    All the cookie stuff seems to be working fine now:

    Set-Cookie: PHPSESSID=2314a9286e9e939cf2e438f41b903c1a; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT

    I am of course first-time browsing this page with a clean browser (firefox).

    This would seem to imply that your browser has some bad cookies or something. I'd suggest clening out your cookies n stuff.

    I was able to sign in and out several times using the demo login
  • I deleted all my cookies; I still can't sign-in, with-out the remember options on.
  • There's nothing in the error log or anything out of the ordinary with the session settings. I'm going to upgrade my version of php and see if that has something to do with it. the server still had version 4, I guess we'll see if upgrading to version 5 makes any difference.
  • ok i poked around a bit and found some differences:

    <br />Response Headers -<br /><br />Connection: close<br />Date: Sun, 15 Oct 2006 23:07:10 GMT<br />Server: Microsoft-IIS/6.0<br />X-Powered-By: ASP.NET, PHP/5.0.4<br />Last-Modified: Sun, 15 Oct 2006 23:07:09 GMT<br />Content-Type: text/html; charset=utf-8<br />Set-Cookie: PHPSESSID=9999e8dfaa2236f1661d128e03e13b81; path=/<br />Expires: Thu, 19 Nov 1981 08:52:00 GMT<br />Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0<br />Pragma: no-cache<br /><br />200 OK

    Response Headers -<br /><br />Date: Sun, 15 Oct 2006 23:08:20 GMT<br />Server: Apache/2.0.52 (Red Hat)<br />X-Powered-By: PHP/4.3.9<br />Expires: Thu, 19 Nov 1981 08:52:00 GMT<br />Last-Modified: Sun, 15 Oct 2006 23:08:20 GMT<br />Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0<br />Pragma: no-cache<br />Connection: close<br />Transfer-Encoding: chunked<br />Content-Type: text/html; charset=utf-8<br /><br />200 OK

    My home test:
    Response Headers -<br /><br />Date: Sun, 15 Oct 2006 23:08:58 GMT<br />Server: Apache/1.3.33 (Darwin) PHP/4.3.11<br />X-Powered-By: PHP/4.3.11<br />Expires: Thu, 19 Nov 1981 08:52:00 GMT<br />Last-Modified: Sun, 15 Oct 2006 23:08:58 GMT<br />Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0<br />Pragma: no-cache<br />Keep-Alive: timeout=15, max=98<br />Connection: Keep-Alive<br />Transfer-Encoding: chunked<br />Content-Type: text/html; charset=utf-8<br /><br />200 OK

    Perhaps has something to do with you running PHP 5 ? ( i dont know if vanilla is 100% compatible with php 5 yet, or even if php5 is finalised (standardised etc.))

    Note that yours has a php session id and path. the others dont. not even lussumo.
    Perhaps something relating to the cookie lacking a more specific path than \ , im not sure.

    I'd certainly move to a more stable php version (4.3.x) though.

    hope that sheds some light on the subject.
  • that's weird.. i didn't think i was on php5 on that server?
  • edited October 2006
    yep, Microsoft Windows Internet Information Server with PHP5:

    Server: Microsoft-IIS/6.0<br />X-Powered-By: ASP.NET, PHP/5.0.4
  • i guess i am... but man how freaking long is php5 not gonna be stable?
  • Vanilla runs fine on my test server, and I'm using php 5.
This discussion has been closed.