Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Posting Youtube Video Into A Discussion

edited October 2008 in Vanilla 1.0 Help
I wanted to be able to post Youtube videos into a discussion but when I copy and paste the embed code it only shows the code and not the video. Does anyone have any experience with doing this and if so did you run into the same problem? Maybe it's the editor that I'm using? Any suggestions would be appreciated.

Comments

  • yes, by default, vanilla comments are text. The html formatter allows html in comments, but i think it would strip out youtube stuff. (try it, though) There's an extension called like JQmedia (requires JQuery) that does exactly what you need.
    Tama
  • edited January 2008
    HTML formatter is specifically built to easily embed videos.



    Just read the documentation, and use these bits of html.





  • dan39, thank you.

    I tried adding that code in a few diferent instances and can't figure out which is which. CAn you take a look on this page. I have enabled the html formatter extension also.

    http://www.suboxone-doctor.com/comments.php?DiscussionID=19
  • it looks like, although you have the html formatter, you chose text. Make sure your permissions say you can use html, andthen edit it and choose Format comments as: html (at the bottom of the textbox, above 'add your comments')
  • I checked to be sure the admin role could post images and html and also was sure to choose html format above 'add your comments.'

    It looks like the code isn't rendering at all but the video ID is still there.
  • edited January 2008
    I believe you need to enable to function on line 57 of the HTML Formatter (v 2.4) default.php.

    define('HTML_VIDEO_TAG', 0);

    Just change it to a 1
  • edited January 2008
    I actually did do that...changed to 1. So just to recap: I am using html formatter, I have changed the 0 to 1, and I am making sure to choose the html option to post my comment...any other ideas of what the problem could be?

    I really appreciate the help.
    Erin
  • Thanks dan39, didn't realise HTML Formatter had evolved so much.
    I am still using an earlier version because I made so many hacks to it.

  • I appreciate all of the help so far but does anyone out there have any more suggestions on what the problem could be?
  • edited February 2008
    so i am using JQmedia and i can post videos via link. However if i try to embed the video, it will not work, the same thing happens as the users above. Any idea why? I have enabled HTML VIDEO TAG.
  • edited February 2008
    Have you guys tried successfully posting a video to this forum? First do that to rule out that you are using the correct syntax. Then, try it on your own forum and use Firebug (the Firefox/mozilla extension) to inspect your outputted markup. See if the formatter is replacing your tags with anything, or not.

    Once you are able to give us more information like that, someone will have a better idea of what's going on.
  • edited March 2008
    the change 0 to 1 trick worked for me.
  • RaizeRaize vancouver ✭✭
    edited October 2008
    How to embed YouTube videos using the HTML Formatter extension:

    1) Unzip the Html Formatter Directory

    2) Open "default.php"

    3) Change the 0 in line 57 to a 1: define('HTML_VIDEO_TAG', 0);

    4) Upload and activate the extension as usual

    5) When creating a new discussion, use



    example:

    and make sure you click "format comments as html" beneath the comment editor window.

    6) That was all I had to do to embed youtube videos in my Vanilla 1.1.5a installation. Good Luck!

    P.S. This function works great with the BlogThis extension by Spode
This discussion has been closed.