Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

404 File Not Found - On the Index Page!



  • Options
    That's correct; a grid server.

    They're fairly good for the price.
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Okay looks like I found the problem and made the fix in the Dev branch. This should be integrated back to master early next week.
  • Options
    MarkMark Vanilla Staff
    @jbminn - Thanks for the offer, but I won't be able to make it to Defrag. I'm all over the place in November :/
  • Options
    edited November 2009
    anyone figure this out?

    I have a fresh install on mediatemple grid server (installed last night) and I'm getting a 404 if I don't add the index.php to the end of the directory its in.

    I'm on 2.0 Beta downloaded last night on github.
  • Options
    @mark no prob; next time. I'm sure we'll connect soon enough.
  • Options
    okay... I gave up and switched hosts.

    Anyone looking to run Vanillia 2 should not use a Mediatemple Gridserver.
  • Options
    MarkMark Vanilla Staff
    Wow - I'm sorry it had to come to that. I know @Todd has been trying to resolve this issue and he's even contacted the folks at mediatemple so he can set up a test server and sort out the issue.
  • Options
    No problem, I'm sure there will be a reasonable explanation as to why it seems to be doing that on (mt) gs hosting servers. I switched hosts and now have a copy of it running as it should. I've been involved in forums for many years, and love the new approach you're taking as its a nice fresh change from the same old stuff that's come out as of late.
  • Options
    MarkMark Vanilla Staff
  • Options
    LincLinc Detroit Admin
    edited November 2009
    I actually canned my MT account after they told me that, as an older Grid customer, to get MySQL 5 (to run a dev copy of Vanilla) I would need to either cancel and reregister (thereby getting a newer Grid) or wait months for them to get around to moving me. Classy.
  • Options
    Hmm... I had a similar issue running Vanilla 2 for development locally using OS X 10.6.2's Apache and PHP 5.3.0 set-up — I could see index.php just fine, but for anything else I'd get a "404 not found." This URL would work:


    but this would 404:

    I added a RewriteBase directive to the .htaccess and that resolved things for me. Worth a shot! My final .htaccess:

    <IfModule mod_rewrite.c> RewriteEngine On RewriteBase /~fred/forum2/ RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php/$1 [QSA,L] </IfModule>
  • Options
    LincLinc Detroit Admin
    Good fix, thanks @FoxyFred. That's in every Wordpress .htaccess file too, of course. Didn't even occur to me to try that.
  • Options
    I wasn't able to get the RewriteBase working for me, so I tired to add this line to the top of my .htaccess and it works flawlessly.
    DirectoryIndex index.php/
  • Options
    I also have Media Temple Grid Service and MatthewAlan's solution above is all that is needed.
  • Options
    didnt work for me. I am able to get to the index page now but all threads give me 404 errors now. Im on dreamhost. If there is no solution how do I uncheck the vanilla rewrite option as I am unable to uncheck it in the UI now.
  • Options
    edited December 2009
    nevermind that uncheck part went into conf.php

    $Configuration['Garden']['RewriteUrls'] = FALSE;

    still wondering why it doesnt like rewrite its probably a dreamhost thing.
  • Options
    Glad my fix worked for you!
  • Options
    I agree that RewriteBase is the key. If you've installed the forum in the root of your site then use:
    RewriteBase /

    If the forum is in a subfolder, then

    RewriteBase /subfolder/

    You do have to be careful that when using Vanilla 2 in a subfolder you aren't messing with the rewriting for it in the site root too though (check the .htaccess in the site root to make sure that real directories are untouched).

  • Options
    edited January 2010
    I'm on mediatemple too, and I have (almost) the same problem.

    the 404 page is not appearing anymore, and every wrong url brings to a Fatal Error (!!!!)
    here's the installation

    and here's the htaccess

    RewriteEngine On
    RewriteBase /v2/
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php/$1 [QSA,L]

    how could I bring back the 404 page?
    what's the correct (default) setting for the routes configuration?
  • Options
    Having trouble with DreamHost (or perhaps other hosts) with .htaccess or URL rewriting?

    DreamHost's wiki suggests: "The FastCGI version when paired with Apache 2.2 doesn't seem to like the rewriterule index.php/$1. Instead it prefers index.php?$1 but some CMS don't like that."

    Unfortunately, any combination of ? seems to short-circuit Vanilla 2 in its current form. The fastest fix? Swap from FastCGI to simple CGI.

    See also:
Sign In or Register to comment.