Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Remove a corrupted Add-On?

Our server was hacked and when I tried to log into my blog, the vanilla side had a "fatal error." The info indicated a crashed portion of the WhosOnline add-on. So I went to the server and deleted it. Now the forum loads, but it's got a mess of text at the top as follows:

Warning: include(/Library/WebServer/Documents/ [function.include]: failed to open stream: No such file or directory in /Library/WebServer/Documents/ on line 9

Warning: include() [function.include]: Failed opening '/Library/WebServer/Documents/' for inclusion (include_path='.:/usr/local/bin/pear/PEAR') in /Library/WebServer/Documents/ on line 9

Seems that it's trying to open the add-on that's no longer there and can't. Of course, I can't deactivate it in the extension settings, because it's not there.



  • Options
    edited October 2009
    you need to delete the line
    $Configuration['EnabledPlugins']['WhosOnline'] = 'WhosOnline';

    from conf/config.php
    You may also have to clear out the cache folder at the same time.

  • Options

    Ah, I don't have a config.php file. Old version of Vanilla.

    But you led me to the right place, I think. conf/extensions.php. Removed this line:


    Yup. That fixed it. Thank you for your help!
  • Options
    Sorry i thought u were using my whos online plugin (which is for vanilla2) well im glad that it worked out okay.
Sign In or Register to comment.