Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Attachment Add-on 2.1 Max upload Size

edited October 2009 in Vanilla 2.0 - 2.8
I am using Attachment Add-On 2.1. It works fine and dandy.
However, recently I have a need to upload a file that is 1.5GB in size which
does not seem to work. I have set the max file size to an absurd value but
still no joy. As a workaround I just stuffed the file in the uploads directory
and send a direct link to the person I want the file to go to. Can I create
a discussion and somehow link it to the file using SQL statements? No
idea why it doesn't upload it.


  • Options
    **MORE INFO**
    I found in /var/log/httpd/error_log that the max file size has been exceeded.
    However, the value that it believes the program is set to is substantially lower than
    the value I have it set at in the Extension Configuration page. It seems to not
    actually be changing the Max upload size.
  • Options
    lucluc ✭✭
    edited October 2009
    Check your php.ini, that's the underlying limit there.

    But 1.5GB is definitely not meant to be uploaded via http.
  • Options
    edited October 2009
    I set Max post size to 9000M and Max Upload size to 9000M in /etc/php.ini. Shutdown and restarted Apache. Still no joy.
  • Options
    >>But 1.5GB is definitely not meant to be uploaded via http.

    I agree, but sometimes these things can't be helped. Their network is
    somehow fussing up sftp so they cannot log in to our sftp server. It's basically
    a work around. :-) Just thought I'd see if I could resolve why I couldn't upload it 'properly'.
  • Options
    edited November 2009
    Can you create a file with the following content:

    <?php phpinfo(); ?>

    And look in the output for:

    1.) "Loaded Configuration File"

    2.) uplaod_max_filesize
Sign In or Register to comment.