Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Newbie help - permissions problem?

TonyReeseTonyReese New
edited November 2009 in Vanilla 1.0 Help
Just downloaded Vanilla 1.1.9 and installed it for the first time.
Set up the database OK
I now can't find the original suggestion about which permissions to modify but..

When I log on as administrator, I can do everything except click on Application settings - I get a 403 error - you do not have rights to access vanilla/settings.php
However, I do have those rights, and presumably I access the same file for other things.
As time goes on, say after a few minutes, the 403 error starts coming up on other things that worked earlier, such as extensions.

Is this really a permissions problem, or something else?

My original problem was that I don't see where to change a user's role - that probably ought to have been a separate question

Tony Reese


  • Options
    Hmmm I think it's about file/folder permission, it has nothing to do with the application itself. Your web server needs read/write access to vanilla/settings.php.

    In order to do that : chmod 755 vanilla/settings.php
    If it's not fixing anything, try : chmod 777 vanilla/settings.php, yet it is not recommanded to do that on a production server for security matters.

  • Options
    I tried that.
    As I said, I have access to vanilla/settings.php and all the other options work when I have just logged in.
    But after a few minutes, I get the 403 forbidden message on most of the options
    I am thinking that this is not due to a permissions problem, but something else generating a 403 message.
Sign In or Register to comment.