Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 1.1.10 Released

MarkMark Vanilla Staff
edited November 2009 in Vanilla 1.0 Help
While we've been hard at work getting Vanilla 2 ready for it's official release, others in the community have been hard at work fixing lingering bugs and adding feature refinements to Vanilla 1. Vanilla 1.1.10 is now available. The main changes in this release are replacement of deprecated functions, and updates to Scriptaculous and Prototype.

You can find upgrade instructions here:

And you can download it here:


  • Thank you for not abandoning the good old Vanilla 1.
  • edited November 2009
    Vanilla 2 looks awesome and if it's anything like Vanilla 1, we're in for a real treat!
  • @Simba Cub you can try Vanilla 2 now ;D

    @Mark nice work on this

    Good luck on vanilla 1.2
  • edited December 2009
    @vflix I know I can test out Vanilla 2, but it's not finalised yet, so I'm not gonna set my heart on certain layouts, features et al. :(

  • @Simba_Cub I don't get it, lol.
  • edited January 2010
    @Bac213 I can download a beta copy of Vanilla 2 but it's still in beta, not in RC, so major changes may still be made, fundamentally altering the forum database, meaning that I can't upgrade to the finished version. The very instant a more finalised copy of Vanilla 2 comes out, I'll be installing it into my live environment.
  • @Simba Cub
    I too will be installing V2 into a live environment, I hope this comes soon :)
  • does the rtl addon
    and arabic languege work with vanilla1.1.10
  • edited February 2010
    I too will be installing V2 into a live environment, I hope this comes soon :)
  • Dear All,

    I am unable to install vainlla 1.1.10, I got this error:
    "We came across some problems while checking your permissions...
    Vanilla seems to have been installed already. You will need to remove the conf/settings.php, conf/database.php files, and all database tables in order to run the installer utility again."

    I removed the settings.php and database.php from conf, also I removed all tables!!! But still face same issue!!! Please help me out....

  • I removed the whole database as well!
  • Thanks for the information. I have been waiting for the release of the latest Vanilla, and thanks that I didn't waste my time on waiting in which I really like the new Vanilla 2. I immediately downloaded it.

    Great thanks!

    RegCure Review
  • are you kidding?! vanilla uses Scriptaculous and Prototype?! NOT Jquery? wow, i expected jquery, guess i expected too much. Scriptaculous and Prototype are huge compared to jquery...... that really sucks, that just killed my spirit, i guess i'll just use the ee forum module...
  • "OMG!? you like only visited like TWICE since 2007?! wow, loads of other people visit more often than that, guess i expected too much."

    Please excuse the sarcasm, but really, if you had actually posted something sensible then I doubt I would have responded like that. Besides, just because something is bigger than something else, or even more popular, does not make it better.

    I'm playing Devil's Advocate here since I personally prefer jQuery, but that has no bearing on this discussion either. Something a little more constructive, if you really cared rather than just trolling, might have been something along the lines of "Wow, I can't believe you're not using jQuery exclusively, here's a link to a reworking of Vanilla 1 using jQuery instead of Prototype along with a couple of the more popular plugins that use prototype. Please consider switching to jQuery because.."

    And yes, I know, I shouldn't feed the trolls...
  • edited March 2010
    Scriptaculous is used on two setting pages and when Vanilla was developed it was the best solution.

    Some extensions uses Prototype and Scriptaculous, so we still include them. Also, it is not really worth converting Vanilla 1 to jQuery when Vanilla 2 (which uses jQuery) is around the corner.
  • edited July 2010
    I'm a relative newbie. I installed 1.1.10 and it is all working fine. But, I want the url of my site to be Can this be done? If so, can someone please be kind and point me toward the page that shows me how to change the path. I keep getting 'page not found' errors. I tried changing path in settings and changing the Vanilla folder name in ftp with no luck. Thanks for taking the time.
  • MarkMark Vanilla Staff
    @BayTheMoon - It is best to identify the folder you want first, and then set up the fresh install in there; instead of setting it up and then moving to a different folder. It should be as simple as uploading all of the files to a directory named "forum" within your www root, and then running the installer.
  • edited July 2010
    @Mark - Thanks for the reply mark.
    Just to be clear, I cannot use my ftp window to rename the folder named vanilla.1.1.10. Therefore, for my future attempts, the mistake I made was to upload said folder instead of opening it and uploading it's content?

    I tried re-installing to a folder named 'forum', but it didn't work. when I enter the url I just get a blank page. Any clues please?
  • Can anyone help me with this. I just want my website to have a forum in a folder named forum instead of vanilla 1.1.10
Sign In or Register to comment.