Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Problems with installing Vanilla 2 - "Bonk"?

edited January 2010 in Vanilla 2.0 - 2.8
I run a Vanilla 1 forum currently but am really keen to try out Vanilla 2 in it's current incarnation... problem is I'm having a nightmare trying to install it!

I've encountered many problems, but I've decided to go back to the start and see if I can get some guidance.

So - I've downloaded the most recent version, created a database, and gone to the install directory - http://vanilla2/ (it's local at present).

I am encountering an error page which reads "Bonk" and doesn't really tell me much else! I believe that there is a way to output verbose errors?

Please could someone give me some pointers?

Many thanks, Keir


  • Options
    Hi @iamkeir,

    I saw another thread with a similar issue - you'll need to follow what bean suggested and edit your config file, it should then give you more debug information to help you track down the problem.


  • Options
    Ah, good shout @benno

    So, my error is "file_put_contents(/Users/iamkeir/Sites/vanilla2/cache/locale_mappings.php) [function.file-put-contents]: failed to open stream: Permission denied"

    This is a permissions error I'm guessing - so I gave /cache/ 777 permissions. It then threw up the same error for /conf/ and /uploads/ which I've granted 777 for as well.

    This then took me to the database setup page - I entered my details and was taken to a 404 Page Not Found for http://vanilla2/garden/gardensetup/2

    Is this an .htaccess rewrite problem now?
  • Options
    lucluc ✭✭
    edited January 2010
    Yep, i's linked to .htaccess rewrite.
    Strange that you don't have index.php in your path there, because IIRC, you are able to use ".htaccess rewrite" only after installing garden, and selecting it in the dashboard.

    I'd say, you should open conf/config.php and add:
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    so that garden is rewrite aware too.

  • Options
    Ah ha! I didn't have a .htaccess file in my vanilla directory - I copied the contents of the vanilla download into a folder on my file system but forgot that this wouldn't copy hidden files (such as the .htaccess). I've now copied it across and it's taken me to the Vanilla dashboard - so that's some progress!

    $Configuration['Garden']['RewriteUrls'] is still set to false so why was Vanilla using rewrites from the start even though, like you said, I hadn't specified it to do so in the setup yet?

    I'll report back how I get on from here...
  • Options
    Yeah, I've got my forum setup all nice now. Strangely there was no setting in the admin section for enabling/disabling .htaccess rewriting.

    I've posted an extended "how-to" setup Vanilla because I know there are a lot of people having a hard time... thanks for both of your inputs.

    Extended How-To install Garden/Vanilla 2
  • Options
    lucluc ✭✭
    There is.

    In dashboard/general or (url: garden/settings/configure), you can enable/disable "Use Garden's .htaccess file to rewrite urls"
  • Options
    Oh yeh, so there is - sorry I missed that. I find it odd that it's disabled by default in the config yet was obviously causing me those initial problems.

    Is this a bug?
  • Options
    lucluc ✭✭
    No idea, it's been a while since I installed one, and I'm using nginx on my own servers anyway, so the setup steps are different.
  • Options
    Hmmness. Ah well, will leave it for now. Thanks for your help, bud
Sign In or Register to comment.