Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fatal Error on Local Installation

dfoxxdfoxx New
edited January 2010 in Vanilla 2.0 - 2.8
been battling the installation, and i've not got very far. vanilla 1 installs fine. vanilla 2 fails each time.

Fatal Error in Gdn_Database.Query();

Database was queried with an empty string.

Application: Garden
Application Version: 1.0
PHP Version: 5.3.0
Operating System: Darwin
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Request Uri: /~dave/garden/index.php/garden/gardensetup
Controller: Gdn_Database
Method: Query


  • Options
    lucluc ✭✭
    check issue 227 (IIRC) on github, and see if you can match my comment to what is happening on your install.
  • Options
    yea i've tried to do that a few times, eventually it gets forwarded to http://localhost/~dave/vanilla2/garden/gardensetup/2 which doesn't exist... vanilla 1 installs fine, so i tried to also use that db and just upgrade to 2, but for whatever reason it just isn't working
  • Options
    I get the same error, they may have to check this out.
  • Options
    lucluc ✭✭
    @iPollesion: I commented on this very issue number.

    If you recreate a brand new install, and fill everything (not migrating from an old v1), does it work?

    If yes, it's just a matter of validation not starting on the first try.
  • Options
    dfoxxdfoxx New
    edited January 2010
    i tried originally from a fresh install, then i tried a migration. the tables in the db seem to be there, but for whatever reason it brings me back the installation page. also it seems to work differently when viewed in firefox. it forwards directly to http://localhost/~dave/vanilla2/garden/gardensetup which returns 404.

    @iPollesion i looked at the before, but i'm not sure what the solution was there. i tried what bean mentioned and no dice.

    it installs fine on my web host, just can't seem to get it working on my machine... so maybe i'll tweak a few things and see what i come up with
  • Options
    ok so i'm not sure what the issue is, but for whatever on my local machine it doesn't seem to follow through on the install /2.. /3.. /4.. /5... so i imported the db from my web host and edited a few things in the config file and it is installed now. but i still can't figure out why it won't work
Sign In or Register to comment.