Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Vanilla 1.1.10 Requirements and Inconsistencies

edited February 2010 in Vanilla 2.0 - 2.8
Howdy people, my first discussion here.

Skipping ceremony, this may be a documentation issue because it is stated that Vanilla requires PHP 5.1 or newer (http://vanillaforums.org/page/Requirements) but the code has some cliché required by PHP4.

I guess the code of Vanilla was ported from PHP4, right? This would explain why public fields were excessively used and objects are still passed by reference. Or perhaps the documentation refers to the new version of Vanilla, but that is pretty unreasonable since it's still under active development.

In both cases there's a clear contradiction between code and documentation, it would be nice to state explicitly to which exact version of Vanilla the documentation refers to.
Good examples are the Doctrine and Zend Framework documentation which display a link (Doctrine) or a dropdown (ZF) to select the documentation version.

Bye

Comments

  • Options
    That's for garden/vanilla2.

    Vanilla1 doc is there: http://lussumo.com/docs
  • Options
    edited February 2010
    Thanks @luc.

    Is Vanilla 2 available? I mean, is it usable?
  • Options
    Yes, cf. documentation tab:
    => "Where to get Vanilla & Garden"

    This very site is using it.
  • Options
    Okay, but the fact that the version offered for dowload is 1.1.10 and the documentation is about the _beta_ version 2.0 is really misleading.
    Don't you think so?

    Bye
  • Options
    He's got a point...
  • Options
    Uh, there is documentation for both and both are available for download. Although Vanilla 1 documentation should probably at least be linked to at the top of the documentation tab here.
  • Options
    Yeah I agree
Sign In or Register to comment.