HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

404 error trying to import Vanilla 1 database into Vanilla 2

edited February 2010 in Vanilla 2.0 - 2.8
Hi all,

Sorry if this has been addressed already, but I searched the community and couldn't find the answer.

I just upgraded from Vanilla 1 to Vanilla 2 & Garden, and installation went successfully.

However, I'm getting an error message while trying to import the old database tables. When I navigate to http://[mydomain].com/import I get the error:

"Not Found

The requested URL /import/ was not found on this server."

(NOTE: "[mydomain]" in the URL is replaced with my actual domain name)


Comments

  • p.s.: I think this may have something to do with the fact that Vanilla is not installed in the root directory of my domain, but a subdirectory as such: http://[mydomain].com/forums/

    But I've tried the import by navigating to http://[mydomain].com/forums/import and that's not working either.

    Please let me know if you have any ideas. Thanks!
  • One more thing. . . when I log in to Vanilla 2, under Site Settings/General the box is unchecked for "Use Garden's .htaccess file to rewrite urls."

    There's an error message below that reads "The server configuration for this setting could not be found. If you enable this setting your site may become unavailable."

    I tried checking this box anyway, and sure enough my site became unavailable (it crashed and I had to do a fresh install).

    Does this mean Vanilla 2/Garden are unable to read the .htaccess file? If they're unable to read it, could this affect their ability to read the URL to run the import script?

    Your input is greatly appreciated. Thanks!
  • OK, it seems part of my problem is that URLs were not rewriting properly. I should mention that I'm on a MediaTemple grid server. I could not get to Vanilla 2 by going to http://[mydomain].com/forums/

    I would get the Apache 404 error. I would have to go to http://[mydomain].com/forums/index.php/

    But the rewrite is working now thanks to the fix provided by @MatthewAlan (thanks!): http://vanillaforums.org/discussion/comment/98841/#Comment_98841

    So now I can get to Vanilla 2 at http://[mydomain].com/forums/

    But I'm still having the problem with the import (Vanilla 1) script. http://[mydomain].com/import and http://[mydomain].com/forums/import both result in the same Apache 404.

    Any ideas? Thanks!
  • MarkMark Vanilla Staff
    Try turning off url rewriting by adding this to your conf/config.php file:

    $Configuration['Garden']['RewriteUrls'] = FALSE;

    Then access the importer with:

    domain.com/path/to/forum/index.php/garden/import
Sign In or Register to comment.