Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Problem Importing from Vanilla 1

edited March 2010 in Vanilla 2.0 - 2.8
I installed/upgraded as recommended, set up the database and an admin-account.
But when I enter xxx/index.php/import I get the following:

Warning: Cannot modify header information - headers already sent by (output started at xxx/forum/applications/garden/controllers/import.php:37) in xxx/forum/library/core/functions.error.php on line 29

Fatal Error in PHP.ErrorHandler();

gzopen(xxx/forum/uploads/export 2010-02-08 152725.txt.gz) [function.gzopen]: failed to open stream: No such file or directory

The error occurred on or near: xxx/forum/applications/garden/models/class.importmodel.php

81: public function SplitFile($Path) {

82: $Tables = array();


84: // Open the import file.

85: $fpin = gzopen($Path, 'rb');

86: $fpout = NULL;


88: // Make sure it has the proper header.

89: $Header = fgets($fpin);


[xxxt/forum/library/core/functions.error.php:132] PHP::include();

[xxx/forum/library/core/functions.error.php:132] PHP::ErrorHandler();

[xxx/forum/applications/garden/models/class.importmodel.php:85] PHP::gzopen();

[xxx/forum/applications/garden/controllers/import.php:40] Gdn_ImportModel->SplitFile();

[xxx/forum/library/core/class.dispatcher.php:227] ImportController->Index();

[xxx/forum/index.php:41] Gdn_Dispatcher->Dispatch();

Variables in local scope:

[Path] 'xxx/forum/uploads/export 2010-02-08 152725.txt.gz'

[Tables] array (

Additional information for support personnel:

Application: Garden

Application Version: 1.0

PHP Version: 5.2.12

Operating System: SunOS

User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; de-de) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10

Request Uri: /index.php/import

Controller: PHP

Method: ErrorHandler

Any Ideas?



  • Options
    I already deleted all files and reinstalled, no change...
  • Options
    I tried visiting xxx/forum/index.php/upgrade and everything worked like a charm!
Sign In or Register to comment.