HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Installing Vanilla on IIS - returns blank page

edited November 2005 in Vanilla 1.0 Help
Hi everyone,

I'm installing Vanilla on IIS and have got PHP working (see test page here), but when I try and load Vanilla it just returns a blank page. I've got the permissions right, I think, and the MySQL database is setup correctly, I think.

Anyone got any suggestions?

Paul.

Comments

  • MarkMark Vanilla Staff
    edited October 2005
    // nm
  • MarkMark Vanilla Staff
    edited October 2005
    Okay, I did a bit of digging, and you're not the first person this has happened to. Sadly, however, I couldn't find a quick resolution for you.

    Others that have had problems like this have found that it might be due to their ftp programs messing up the files as they upload them. If I were to guess, I'd say that it has something to do with the fact that you're running php 5 and it hasn't been configured to work with php 4.x class definitions. I can't remember what the php.ini configuration setting is, but it's something like php4.compatibility... sorry - swamped with work and can't figure it out for you right now.

    Anyone else have any ideas?
  • NickENickE New
    edited October 2005
    I've sometimes had a blank screen appear on a fatal MySQL error. Maybe you should double check all the settings are correct. Or, perhaps, PHP is set to display no errors at all, so you're getting a blank page when there's actually some sort of error occuring.
  • edited November 2005
    Could be the header problem... WordPress had the same problem with IIS

    It could be fixed by replacing header("Location: )" by this code:
    if( strstr($_SERVER['SERVER_SOFTWARE'], 'Microsoft-IIS')) header("Refresh: 0;url=$location"); else header("Location: $location");
    But that's a nasty fix... Maybe Mark should look into it ;)
  • edited November 2005
    I'm having the same problem with my IIS installation. I can get through until Step 2. No matter what I put in for the MySQL paramaters, it returns a blank page. I've verified that is not permissions by just granting everyone full control and testing. I'm not too literate with MySQL, but based on the fact that it returns a blank page no matter what, I'm thinking it is not related to the MySQL settings.
  • I don't think it's MySQL related... everytime data is saved, you're getting redirected and that's were it goes wrong :) But then again... I'm also hosting on an IIS install.... could be the PHP version...
  • edited November 2005
    I am trying to get it running on a Windows Server 2003 running IIS/PHP 5.0.5. What about you?
  • edited November 2005
    I have Windows Server 2003 with IIS, but I use an older PHP version 4.3.11 and MySQL version 4.1
  • edited November 2005
    Okay, I'm getting closer. I've downgraded PHP to 4.4.1 and now it doesn't bring back a blank page. It does bring back the error "Oops. We came across some problems while setting up Vanilla... We couldn't connect to the server you provided (localhost). Are you sure you entered the right server, username and password?" The database is created and I am able to connect to MySQL server using localhost, root, <pwd> with the MySQL Administrator so I'm not sure why it won't connect.
  • MarkMark Vanilla Staff
    edited July 2006
    Doing basic connection tests with mysql is pretty easy. Create a new blank text file called mysqltest.php and put this inside:
    <?php
    // Turn on all errors
    error_reporting(E_ALL);
    
    // Customize your database connection
    $Host = "Your MySQL Host Name";
    $User = "Your MySQL Username";
    $Password = "Your MySQL Password";
    $Database = "Your MySQL database name";
    
    // Open a database connection (you may see some errors here)
    $Connection = mysql_connect($Host, $User, $Password);
    
    // Attempt to select your database
    if ($Connection && !mysql_select_db($Database, $Connection)) echo("Failed to connect to the '".$Database."' database.");
    ?>
    Give that a go and see what happens.
  • Now we're getting somewhere: Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client
  • MarkMark Vanilla Staff
    according to the textpattern folks, it's a hosting company problem: http://textpattern.com/faq/96/client-does-not-support-authentication-protocol-requested-by-server
  • This is my own server and I didn't realize when I downgraded my PHP that I needed to downgrade MySQL. Let me give that a shot...
  • I downgraded to MySQL 4.1 and PHP 4.4.1 and get the same error: "Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client" What version combination does Vanilla Recommend?
  • MarkMark Vanilla Staff
    edited November 2005
    I knew i had seen this one before. After some digging here on the forum, I found that jonezy had the same problem and solved it here:

    http://forums.mysql.com/read.php?11,6400,10611#msg-10611
This discussion has been closed.