Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Sub Domain Forum Login

edited November 2005 in Vanilla 1.0 Help
I have searched the forums here, and tried several different things to fix the problem even looking threw some of the code but have yet to find an answer.

I have Vannila setup as a sub domain of the main domain like forum.whatever.net.

Problem:
When I go to signin.php and enter login information and click proceed it tries to go to http://forum.whatever.net\/ which doesn’t work, I can click proceed again in Firefox or remove the \ from the url and it will allow me to continue to the forum with the name I signed in with.

Extra Info:
* The server is running IIS for web hosting I have fixed all other problems like the extensions for PHP5 ect.
* Tried changing the Web-path to Vanilla to forum.whatever.net, ./, and nothing/left blank. All did not fix the problem.
* I upgraded the forum from 0.9.2.2 to 0.9.2.5 a day or two ago but am still using the same DB, problem was still a there with the older build.

Thanks for any light on the subject.

Comments

  • lechlech Chicagoland
    what do you have set for the cookie domain?
  • Sorta gives me the impression there's too many escaping slashes somewhere but i havent seen this before so it seems unlikely.
  • I have tried setting the cookie domain to: * forum.whatever.net * whatever.net * whatever.net/ * forum.whatever.net/ I also after every settings change made sure that the cookies were deleted from my internet cache to make super sure it was not getting mistaken. To me the problem seams to be just after the cookie information/session is started because if I got back to the main dir/index.php it shows me logged in meaning it sent me all the correct info but some where in the redirect or refresh that happens after every thing ells a linking is not right, or at least thats what it looks like to me. I really don’t know the order that Vanilla is setup for logging in. Thanks for the suggestions, I will keep looking into myself too.
  • lechlech Chicagoland
    ok, I'll give you the benefit of the doubt and guess you're not actually using '*' before those entries, because that would be a bad thing. I would say for now, just try using:
    <strong>.whatever.net/</strong>
    With preceeding persion, and that should resolve to the entire tld and any subdomains the forum is running under. If that doesn't appear to work, feel free to drop a link to your forum plus a phpinfo(); page, as it could be helpful to determine what's up with either your server/php install or Vanilla itself.

    Mark, have you fixed cookies in these latest update builds or is that still getting implimented for the next release?
  • edited November 2005
    I setup the complete test forum to test default settings from scratch and found after two installs and two drops of the test forum both times it trys to put in appg\settings.php
    Line: 30 define("agDOMAIN", "forum2.clx.serveftp.com\");so not even the main page opens up etc, and if I manually remove \ from the settings.php the pages loads right but I’m back to the entering username and password, I get forum2.clx.serveftp.com\ cannot be found and if I go back to main dir/index.php it shows me signed in.

    Ok tied the .whatever.net/ but didn’t help eather.

    Testing sub domain setup:
    http://forum2.clx.serveftp.com/PHPInfo.php User: freebie Pass: efx
    http://forum2.clx.serveftp.com/signin.php
  • lechlech Chicagoland
    \ != / , but this looks like a possible php5 flub from what I can tell. I'll let Mark take a stab at this one as it looks more like his dept at diagnosing what is the likely culprit.
  • Ok thanks I will keep checking in to see if anything new comes up to help with the problem and browse around to see if I can help out anywhere too. Thanks
This discussion has been closed.