Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

BBInsertBar 0.1.5 issues with FF

edited April 2010 in Vanilla 2.0 - 2.8
Well, I installed the extension in my blog and if I used Firefox and clicked "HTML\BBCODE" (In my case, I've disabled BBcode ATM but the same thing happens with or without BBCode) and click buttons like Bold, Italic, Underline and Strike, it just adds the letter next to the button while it works perfectly in Internet Explorer's case.

Any idea?


  • I checked with a friend of mine and said that it works fine with Google Chrome...
  • Have you tried the unofficial 0.1.9 version? I haven't, and I didn't really change all that much code, but... worth a try no? :D
  • Same thing... I think it does that whenever the function "insert" is called, works well with other functions such as "insertURL"
  • Hmm, I'm not sure what is going wrong for you since it seems to work just fine for me in Firefox 2, 3, 3.5 and 3.6 in either HTML or BBCode mode. What specifically is going wrong for you?
  • Is this site online yet? Any chance you could send me a link so I could see it?

    Failing that, would you be willing to zip up your entire Vanilla directory so I can take a look at it locally?
  • Hmmmm... Hold on... It'll take a day or two (Leave notice is annoying)
  • Check your messages
  • Hmm, seems to be a conflict with one of the other extensions. Considering you have MooTools, Prototype/Scriptaculous AND jQuery libraries all firing on your pages, I'm surprised you don't have more trouble!

    Just looking quickly, UserInfo (which is MooTools based IIRC) is throwing an error, so try disabling that and MooTools - then see if things improve. I don't have time to look more thoroughly I'm afraid.
  • Just did, same thing -_-;
  • Hi, I wanna build a bbs like here, what shall i do?
  • @Q8geek, sorry, just haven't had the time to look into this properly yet. I'll see what I can do in the next few days.

    @abrody, you should start by reading through the docs and then starting a new discussion if you need more help.
  • I'd deeply appreciate it =D
  • Right, I just used your ZIP and installed it locally on a fresh databases (obviously I don't have yours). BBInsertBar seems to be working fine :/

    You're not going to like this suggestion, but if I were you, I would disable EVERYTHING barring the HTML formatter and BBInsertBar. Check to see if it works then. If it doesn't, then something *REALLY* strange is going on, and I'd disable both plugins, uninstall them, re-download, reinstall and re-enable them and test again, hopefully by that point they should be working.
  • Looking a bit closer I notice that if you start a new discussion, the bar works just fine.

    Here are the javascripts that show up in the source for existing discussions but not in the source for a new discussion
    <script type="text/javascript" src="/forums/1/extensions/LiveDiscussions/mootools.js"></script>
    <script type="text/javascript" src="/forums/1/extensions/LiveDiscussions/live.js"></script>

    <script type="text/javascript" src="/forums/1/js/prototype.js"></script>
    <script type="text/javascript" src="/forums/1/js/scriptaculous.js"></script>
    <script type="text/javascript" src="/forums/1/extensions/ReportComment/rc_ajax.js"></script>

    <script type="text/javascript" src="/forums/1/extensions/Poll/functions.js"></script>

    <script type="text/javascript">
    LiveDiscussion.Page = 'comments';
    LiveDiscussion.PageNum = '2';
    LiveDiscussion.Id = '46';
    LiveDiscussion.Timer = 30 * 1000;
    LiveDiscussion.Root = '/forums/1/';
    LiveDiscussion.CommentColour = new Color('#E5EAF6');
    LiveDiscussion.Theme = 'vanilla';
    LiveDiscussion.Translate.extend(['Live Discussions', 'Live Updates are On', 'Live Updates are Off', 'Started by', 'Last comment by', 'Category', 'Comments', 'Last Active desu', 'New']);
    I bet you it is one of these. So try disabling those first before you turn EVERYTHING off.
  • I tried what you said, things worked well after disabling "Notifi 2.0.4"
  • Hahahaha! Notifi *again*?! Ah well, glad you found out what's causing it. Wonder if we can get an update on Notifi - seems to clash with a lot of things...
Sign In or Register to comment.