Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Quick WYSIWYG for Vanilla 2 + now with Addon!



  • Someone please help, I installed the plug-in but it's not working. Do I have to do any extra steps to get it to work or something?

    It also seems that my forum just randomly supports BBCode, not that this is a bad thing cause I want to use BBCode but I never put that function in and I think it's ''interfering'' with this plugin. Could someone help me out please? :)
  • @Nimaveli: It should 'just work' - are you running the final release of Vanilla2?
  • Yes I am, here's a link to my forum if that helps you figure out the problem;

  • @Nimaveli: I don't see the references to the plugin's .js and .css files in your page source.

    Try editing plugins/jwysiwyg/default.php, on lines 39 & 40 remove the leading-slash before "plugins" in the file urls.

    Then disable/enable the plugin and reload the site and let us know if it works.
  • NimaveliNimaveli New
    edited July 2010
    Hmm, I tried doing that but unfortunatly it still doesn't work D:
  • @Nimaveli: I reloaded your site and can now see the .js and .css referenced correctly.

    Are you seeing any other errors?

    What other plugins do you have loaded?
  • NimaveliNimaveli New
    edited July 2010
    These are the other plugins I got activated right now;

    Whos online
    HtmLawed Flagging
    Getting Started
  • @Nimaveli: Try disabling everything expect HtmlLawed and see if it works.
  • @Rak
    Tried that out, didn't help :(
  • @Nimaveli: Maybe it's the theme, can you switch back to the default theme and see if it works?
  • @Rak
    Nope, switched to the default theme and still had this problem. This is very weird...
  • @Nimaveli: Very weird!

    Try turning on debugger mode, edit conf/config.php and remove this line:
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';
    Reload the site and you should see a list of debug info at the bottom, copy/paste that here and maybe we can figure it out.
  • @Rak
    hmm, that's weird. I managed to delete that after downloading the config.php, changing it then uploading it again(it just wouldn't change otherwise) but I see no debug info at the bottom. I even tried using that debugger plug-in but didn't see anything either. Somethings seriously wrong with my forum :(
  • @Nimaveli: you could try a clean install in another folder and see if it's a problem with the current installation. Good luck!
  • NimaveliNimaveli New
    edited July 2010
    I saw another topic on this forum about the plug-in not working cause the forum is in a subdirectory. Could that be the case here? Really don't want to lose everything again :(
  • rakrak
    edited July 2010
    @Nimaveli: I'm not sure if being in a subdirectory is an issue. To check, edit plugins/jwysiwyg/default.php add the full path to lines 39 & 40, so they read:
    $Sender->Head->AddString('<script src="" type="text/javascript"></script>');
    $Sender->Head->AddString('<link rel="stylesheet" href="" type="text/css" />');
  • @rak: With the full path inserted in the default.php as you suggest above, the format bar works!!!! :D

  • @bughead: glad it works! is your installation in a subdirectory?
  • @rak: I don't know hehehe

    It's local for test purposes only! In a near future I'll implement it in my store! :D

    Here it's at: http://localhost:8888/vanilla/

    My next "quest" is a brazilian portuguese translation ... next week I'll work on it ... if I discover how to do it. hehe

    Thank you very much for the help!!
  • The plugin works, but if you're using a plugin like Quote or Quote Selection, you'll have to modify the javascript so that it sends the quotes to the new textarea that you've created.

    I'm not sure what the new ID is, I've not looked in the code much yet.
Sign In or Register to comment.