Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Redirect Loop when trying to install Vanilla 2 RC

edited May 2010 in Vanilla 2.0 - 2.8

I'm trying to install the Vanilla 2 RC-version.
The last versions all could be installed to my webspace.
I deleted all the old files and copied the new ones onto the server.
But when I try to access my forum's address, I always get a redirection error!

Firefox says:

Redirect Loop

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

It seems like it's getting redirected from to to to and so on...

I'm using a .hhtaccess-file which worked like a charm until now:

DirectoryIndex index.php/

Options +FollowSymLinks
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*) index.php/$1 [L,R=301]

When using the .htaccess-file from github, it redirects to but says "No input file specified."

Any ideas what causes the loop?
It worked well before...



  • Options
    TimTim Operations Vanilla Staff
    You should definitely be using the provided .htaccess file and not the one you pasted here. As for why you are getting that error, I'm not 100% certain but it sounds like you're using FastCGI and PHP's fcgi daemon is not being passed the right script argument.

    During some of my early experiments with nginx I found that replacing
    RewriteRule ^(.*)$ index.php/$1 [QSA,L]

    RewriteRule ^(.*)$ index.php?rewrite=$1 [QSA,L]

    helped out a bit. I'm still not sure what the error is though, we've tested quite extensively on different configurations and worked through quite a slew of issues.

    Can you provide more details about your environment?
    Apache Version, PHP version, PHP interface mode [php_sapi_name()], Operating System

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    I tried changing the .htaccess file like you recommended. But I still get the Redirect Loop on

    My Webspace:

    Apache/2.2.15 (Unix)
    PHP Version 5.2.12

    The Server is using CGI-PHP

    Is there anything I could try by altering the php.ini?
  • Options
    this sounds very close to the same issue i have,
  • Options
    are you using the most recent github RC branch? Im having a issue with main page installer not loading. Could be related.
  • Options
    @bobtheman Yes, I am!
  • Options
    *whistles. any luck?
  • Options
    not yet...
  • Options
    nope... no joy here either...
Sign In or Register to comment.