Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

New users are not being able to sign in

edited June 2010 in Vanilla 2.0 - 2.8
I just recently set up a Vanilla 2 forum and have tested it with signing up a couple of users with different email accounts that I have and I can't sign in with any of them except for my main account. All that comes up is a blue rectangle with a x in the right hand side. My forum is

Thanx for your help :)


  • Options
    TimTim Operations Vanilla Staff
    edited June 2010
    I'm not cure what's causing this, but when I tried to sign up, it felt like it hadn't really added me to the database. Check your dashboard under 'Users' and see if you actually have anyone properly signed up to the forum.

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    @SashKat: your issue might refer to this one posted at GitHub?
  • Options
    In users I have three signed up. Me, me again but under a different email to test and you Tim.

    Perhaps the MySQL permissions haven't been set up properly?

    I also tried resending the password to my other email and got the following error:

    SMTP Error: Could not connect to SMTP host.
    Fatal error: Call to undefined method Exception::getContext() in /home/allykatd/public_html/forum/library/core/functions.error.php on line 57
  • Options
    TimTim Operations Vanilla Staff

    Well that second error is easy to fix. If you look at /home/allykatd/public_html/forum/library/core/functions.error.php you'll see that line 57 probably contains something like this:
    $Arguments = $Exception->getContext();
    Simply changing that code to the following should eliminate the error:
    		if(method_exists($Exception, 'getContext'))
    $Arguments = $Exception->getContext();
    $Arguments = '';
    On the other hand, you could update to the latest RC code where this and several other bugs have been fixed.

    The sign in problem... that's more tricky. Could you check that you conf/config.php file and tell me if your $Configuration['Garden']['Cookie']['Domain'] setting exactly matches your domain name?

    Vanilla Forums COO [GitHub, Twitter,]

Sign In or Register to comment.