Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2.0 RC2 - Can't sign in

edited June 2010 in Vanilla 2.0 - 2.8
I'm really not sure what's going on here. I've done two completely clean installs of RC2, setup the databases and such, and then it redirects me to the forum asking me to sign in. I enter in my username/password and it spins the little load wheel, and that's that. It doesn't actually sign me in.

I know this must be some incredibly simple problem that I've overlooked, but my brain is fried from my day job. Anyone feel like making me look like a fool and pointing out what I've done wrong?


  • TimTim Operations Vanilla Staff
    Cookie Domain ?

    Vanilla Forums COO [GitHub, Twitter,]

  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    @michaelalfox I had the same issue locally, when I had set a Cookie Domain in the config.php. I then just left it blank, and suddenly everything worked.
  • edited June 2010
    My Cookie Domain is currently set to ''. I guess I'll try it blank to see if that fixes it. I'm kind of wondering why having my site as the cookie domain would cause this problem, though. I really don't know all that much about cookies other than the fact that they're delicious.

    Edit: Yuppers, leaving it blank fixed it. Although, will this cause me any problems by doing it this way?
  • i just installed RC2. I was able to get to setup and enter database information. Now i can get to the homepage. However, when i click the sign-in button, the box pops up but i never actually get anywhere to enter a user/pass. Any advice?
  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    edited June 2010
    @RjRiley Have you DISabled the config-value "RewriteURL" in config.php? This helped for me - because I had an issue with my .htaccess file and thus the login popup was not displayed properly.
  • @oliverraduner To do so would I simply change the value from TRUE to FALSE?
  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    Yes, @RjRiley
  • Excellent. Now I can sign in as admin, but can't see a dashboard or anything else. HMMMM
  • nevermind...the fix earlier in the thread helped. thanks!
  • No need to change anything guys. Just clear your cookies (or close/re-open your browser).

    I've sent in a ticket on the issue.
Sign In or Register to comment.