Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Guest Welcome Message



  • Options
    Herrgeist: When I need to change a color on a webpage, I use Eye dropper. You will have to right-click on it and check the box next to 'show RGB' to see the hex mode color notation that is used in CSS, then just find that color sequence in the CSS and change it.

    CSS also has a three character shorthand, so something like #CCC is the same color as #CCCCCC. White is #FFF (or in longhand #FFFFFF), black is #000.
  • Options
    Yeah, I do the same thing with Photoshop to get the code. I just can't figure out where the color code to edit is.
  • Options
    Boy I feel dumb now. The extension doesn't even have a CSS file...

    It looks like it uses the .Notice section (it's relatively close to the top) in the themes/vanilla/styles/default/vanilla.css file: background: url(notice.gif) left center no-repeat #FFFECC;
  • Options
    ah I see. Thank you for that.
  • Options
    Thanks a lot, great add-on, it solved me for the newbies who get confused :D
  • Options
    Thank you so much for a great post, Works like a charm :)
  • Options
    I want the guest welcome message only on my start page. This ist the BlogThis page (extension.php?PostBackAction=Blog) How do I have to modify the default.php? Simply adding extension.php to the array and delete everything else does not work. Then the message is displayed on every extensions page. thanks
  • Options
    I have installed this extension but I cannot find the interface to change the setting. I have looked in roles& permissions to enable it, but there is nothing there. The extension is enabled in the extensions page. I went and edited the php file, but the change didn't work.
  • Options
    Hey, maybe someone will find it useful, I updated this extension so it points where terms of service are for authenticated users.
    To make it work you have to do 2 things,
    add a line like so to settings.php in /conf folder
    and define your message, like so
    $Context->Dictionary['TermsOfServiceMessage'] = 'Looking for Terms of Service? It's here.';
    in definition.php inside guest welcome extension.

    if (in_array($Context->SelfUrl, array("account.php", "categories.php", "comments.php", "index.php", "search.php")) && $Context->Session->UserID == 0) {
    else if (in_array($Context->SelfUrl, array("index.php")) && $Configuration['TERMSOFSERVICE_MESSAGE'] != '') {
    Cheers, :)
Sign In or Register to comment.