Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.


This discussion is related to the Transmogrifier addon.
edited March 2007 in Vanilla 1.0 Help


  • This extension is quite essential to my Esperanto forum. Because many of my users are not able to directly type the Esperanto accented characters (ĉ, ĝ, Ä¥, ĵ, ŝ and Å­), I use Transmogrifier to allow them to type alternative character pairs, which get automatically changed to the appropriate accented letter. It works like a charm, and the users *really* like it.

    The latest upgrade of the "Post Preview" extension makes it also fully compatible with Transmogrifier, which makes it a bonus! :-)

    Ever since I installed it, though, there has been a couple of problems with Transmogrifier, which I keep on hoping will eventually be solved:

    1) Transmogrifier does not apply its 'magic' to the titles of discussions - so when users start a new discussion, if the title has an accented character, I must go in as 'admin' and manually change the title directly. It would, of course, be fantastic if Transmogrifier could also transmogrify those titles.

    2) Transmogrifier does not apply its magic to the content of pages created with the "Page Manager" add on. Again, that would be a wonderful addition to this already excellent extension to Vanilla!

    Please, Bergamot, keep up the good work! - It is very, very much appreciated! :-)

    You can see its magic at work in our forum here. To see how I've got it setup, have a look at the FAQs, under "Typing Esperanto Accents".
  • Uploaded version 1.2 of Transmogrifier.
  • Hi, I've just added the following to my config.txt file: [cut] == <font color="red"><strike> [/cut] == </font></strike> and I've recieved the following error: Warning: preg_replace(): Unknown modifier 'c' in /home/xxx/public_html/xxxxxxxx/forums/extensions/Transmogrifier/default.php on line 56 Everything works fine without this latest piece of custom code I added. Any way to correct this? Thanks
  • I know this isn't a solution to this problem, but you can get this using [s][/s] in BBCodeParser and then just add this to vanilla.css:del {color:red !important;}
  • I thought I might also add that the following works.. +s+ == <strike> +\s+ == </strike> However, +/s+ does not. There seems to be some sort of rejection for the / character
  • @vaz - this isn't what you posted about, and i doubt it's related to the problem, but in the original example, you closed the font/strike tags in the wrong order. sorry, i'm a validation nerd :)
  • An update!!!! GREEEEEEEEEEEEEEEEEEAT!!! :-D Does anyone know what's new?
  • @guazy [cut] == <font color="red"><strike> [/cut] == </font></strike> Let's even try that then. It pops up an error unless you change [/cut] into [\cut] :D
  • @vaz: I think guazy was suggesting you try THIS: [cut] == <font color="red"><strike> [/cut] == </strike></font> Properly formed XML should be nested: "<outertag><innertag></innertag></outertag>"...
  • yes, i was referring to what icouto said:)
  • icouto, sorry, but the new things are just simple fixes suggested by SirNot to convince it to work with PreviewPost.

    Transmogrifier & PreviewPost Extension # 3
    Transmogrifier & PreviewPost Extension # 7
  • @[-Stash-]: thank you for the info! :-)

    Do you know if it would be very difficult to change it, to fix the 2 problems mentioned in the above comment?
  • It would be very difficult for me! I don't really code PHP (or JS) I just hack other people's skilled work around. Someone like Mark, SirNot or Dinoboff may be able to help on those two point. They are certainly very good ideas.
  • Very impressive stuff! And it would be great if this magic could support and replace the 2-byte languages, such as Chinese, Japanese and Korean. I mean I would like to replace any specific word(s) of 2-byte lang with icons. Could you possibly support these languages?
  • Trying to make Google Talk-like emoticons, but I can't get this to work: :) == <span style="color:#0000ff; font-weight:bold">:)</span> It just displays ":)" (unaltered). Any ideas?
  • @kimC, is it a formatter issue? i think all the formatters will accept HTML, but i could be wrong. i'll give it a shot on mine.

    hrm, doing the same thing on my install. not sure why.
  • No idea - maybe the code parses the < or the / chars wrong? But I don't know how to code in php anyway...
  • Can this be made case-insensitive? Or perhaps add an option so that people can choose? I love the extension, though.
  • there is a php function that can convert it to lowercase.
    use that
  • @KimC
    Since Transmogrifier will be skip any line that contain '#'.
    You have two ways to fix it.
    The easiest way, just change '#0000FF' to 'blue' ==> :) == :)
    The second way, change line 39 in default.php
    if($line == "" || $line == "\n" || strstr($line,"#")) by if($line == "" || $line == "\n" || strstr($line,"##")) and add more '#' in the config.txt 's comment (or just remove any comment :P).

    just change line 45 in default.php:
    $this->token[$counter] = '/'.preg_quote($value[0]).'/'; to $this->token[$counter] = '/'.preg_quote($value[0]).'/i';
Sign In or Register to comment.