Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Attachments

This discussion is related to the Attachments addon.
SubJunkSubJunk ✭✭
edited January 2007 in Vanilla 1.0 Help
«134567

Comments

  • I'm probably the only person who does this, but that's not stopping me from making this suggestion anyway... It would be nice if the whole attachment input/button was hidden by default. I find I'm constantly hitting the wrong button when posting (browse instead of post comment). Of all the comments created, only a very small percentage require an attachment. I think it would be sleeker, if only when you needed to attach a file, you would click an expansion box, which would reveal the necessary tools required for the task at hand.
  • Doesn't bother me personally, but I still like the idea :)
  • Yeah, I'm all about clean, context-dependent interfaces.
  • u can edit the file or use CSS to move it to another palce
  • Uploading images works fine. When I try to upload a PDF the following error occurs:
    You are not allowed to upload (filename.pdf) the requested file type: application/force-download
    I tried to find a solution here, but found none. Can anybody help?
  • Man, this needs to go in the FAQ... There's a recent post by me on this, but basically you need to add the "application/force-download" bit to the default.php of Attachements. If you open the file up, you'll see a bunch of lines with that kinda thing in them and you should get the idea - I did and I know *very* little about PHP. Sorry I can't be more descriptive right now, but I'm off to a antenatal class... (search, and you'll find several threads on this).
  • Hello skube,

    I think this is what you were looking for:
    http://lussumo.com/community/discussion/5628/multi-file-upload/
  • You are the man, Jazzman. Thx!
  • Thanks Stash, that works.
  • I've mentioned this before, but got zero response, so I thought I'd try again because I think it's a great idea :)

    Originally from Multi File Upload discussion:
    This extension rocks. Would be nice to have a GUI so we can manually change the max number of uploads, and perhaps also some indication by the upload box that says how many files can be uploaded at once? I have to say that this, combined with ThickBox rocks :) With Inline Images and thumbnails set to 125px, it's like an instant gallery :)

    I have also been thinking a little regarding Attachments' extensions. I personally believe they should go into a subdirectory of the Attachments extension, so something like:/extensions/Attachments/InlineImages /extensions/Attachments/MultiFileUpload /extensions/Attachments/AnotherNewAttchmentsExtension
    After all, they all REQUIRE Attachments to work any way. Then we could perhaps also have their options GUIs selectable from a dropdown menu in the Attachments Extensions Options screen? It would keep things nice and neat and together in the attachment extensions area of the panel. I mean it's fine right now with only two extensions to Attachments, but what about when there are 5, 10, 16?

    This is how I would envisage the admin side looking. The relevant section wouldn't show up if the extension isnt installed.

    Vanilla, extensions, Attachments, mockups, Suggestions to settings, thumb
  • It's a great extension but I've found a minor bug in it. In default.php in three places it says MineType instead of MimeType, which makes it not retrieve the attachment MIME type properly from database. Other than that, everything's perfect, it seems.

    BTW If I may have a suggestion, could you also allow Excel (XLS, application/vnd.ms-excel) and PowerPoint (PPT, application/vnd.ms-powerpoint) files by default in the next release?
  • @CandleWithHare naise that bug is probably the reason for some of my buggy problems... you can add any file type you want in the default.php file. so far I havent been able to see the file type options in the settings page, but have edited it manually. btw, is there a way for it to say just accept all types? i run two private forums where I trust everyone and therefore, want to let them post whatever
  • this add on conflicts with quotes. try to quote a message that has attachments.
    it displays the quote message like this;
    "Mesajlarınıza youtube, google video ve ifilm videoları ekleyebilirsiniz. Yapmanız gereken tek şey video linklerini mesajlarınıza yazmak.[div id=Attachments_16 class=Attachments][ul][div]video.gif[/div][/ul][/div]"
  • Hello, when posting a non-allowed file type I get this message: Some problems were encountered The requested discussion could not be found. I believe the error message is supposed to be something like "this file type is not allowed" or similar. Does anyone know how to fix this? Is it possible to configure this add-on to accept all file types? [edit] I just discovered that I also get the very same error message when deleting a discussion (the discussion gets deleted, and then the error displays). I guess the problem is related to my Vanilla configuration, and not the add-on... Disregard that - seems to be caused by me turning off Deleted comments visible for admins. The attachment-problem still persists...

    Now it's working - probably caused by a recent upgrade of my mediatemple server.
  • I installed it, when i test posting a comment with an attachment, i get the page not found. however, the post is live and its under discussion and the attachment is there also.

    how to fix this issue?
  • Is there any way to manage the uploaded files?
  • I have properly installed this extension, but I cannot add attachments. Why I select an attachment via Browse and then click "Add your comments," I get a red text error that states the following:

    Some problems were encountered
    An error occured while creating a new attachment folder. Check your upload path permissions

    How do I fix this problem?

    (I know how to change permissions on files/folders via my FTP client, so if someone can guide me to the specific files/folders that need to be changed, I would greatly appreciate it. Keep in mind though that I changed all the permissions properly to setup my Vanilla forum, in strict accordance to the 3 step guidelines for setting up Vanilla. Please also note that I have another permissions problem reported here.)
  • Have you made a folder named uploads in your vanilla folder? Also, it needs to be chmodded to 755.
  • Kim, there is more than one "vanilla" folder! There is one inside "library" and another inside "themes." I created an "uploads" folder in "library" and gave it 755 permissions. I tried attaching a file and got no error this time, but my attachment was not saved (doesn't appear in the discussion thread nor is there a file in the "uploads" directory I made). I tried it again, making another "uploads" folder in the root directory (where all my Vanilla files are stored), but when I tried it again I got the same thing -- no error, but no file uploaded.

    Any further suggestions would be greatly appreciated.

    Thank you!
  • The uploads folder needs to be in the main vanilla directory (same level as ajax, appg, conf, extensions, etc.).

    Inside that folder, you need to create another folder called Attachments (note the uppercase A).

    Then check the path in your admin panel for Attachment Settings, and make sure that it matches what you have on your server.
  • You only need to make the uploads-folder, no need for any additional folder inside it (unless you explicit specify that in your Extension settings, that's probably what dhdesign did). With the default settings, the attachments are saved in [your vanilla dir]/uploads/[year]/[month]/
  • dhdesign! Thank you for the extra specifics. I knew there was more to it!

    I deleted the uploads folders I made earlier today. I then went to the root directory where all my Vanilla files are stored and then created a new folder called "uploads". I then opened "uploads" and created a folder named "Attachments". I made sure both folders have 755 permissions.

    I then tried uploading. Just like earlier today though, I get no error but no file uploads.

    I am not following you when you say: "check the path in your admin panel for Attachment Settings"! Where in the world is that? I clicked the Settings tab and checked under all the items (Application Settings, Updates & Reminders, Roles & Persmissions, Registration Settings, Categories, Extensions, Themes & Styles, Languages, and Membership Applications) -- nothing that says "Attachment Settings." I then clicked the Account tab and checked everything there (Personal Information, Change Password, Change Role, Forum Preferences, Languages) -- nothing that says "Attachment Settings."

    Am I losing my mind! I think so!

    kimC, like I said, it's just not working. Earlier today I created an "uploads" folder in my root directory. I didn't create a "year" or "month" sub-directory, but I don't have to right? And what of these mysterious "Attachment Settings" that dhdesign speaks of?

    Thanks.
  • i think its pretty obvious you need to solve the database problem before looking to fix anything else JDW. check my reply on the other thread
  • JDW -

    The uploads folder can be set at 755, but make sure the Attachments folder inside it has its permissions set to 777 so that the uploaded file can be saved.

    Attachments Settings is found in the Settings tab under Extension Options, at the bottom of the left panel. That is where you set your path - it will probably look something ilke this: /home/yourusername/public_html/yourdomain/vanillafoldername/uploads/Attachments/. You will need to add the appropriate tags to designate how you want your uploads sorted (i.e., %day%, %month%, %year%, %userid%), if you want them sorted. Mine is set for %year%/%userid%/. Make sure you put the trailing slash at the end, after the last tag.

    You don't need to create any other folders inside the Attachments for day, month, year, or userid - Vanilla will create the appropriate folders when you upload an attachment.

    Hope this helps!
  • Thank you for the advice on setting the Attachments folder to 777. I have now done that (leaving the outside folder "uploads" set to the default 755 permissions).

    Thank you for the specifics on where the Attachment Settings option should be found. Sadly, it is no where to be found. As I mentioned in my post above, you can see that no such "Attachment Settings" exists anywhere in Vanilla when I am logged in as an Admin. Here's a screenshot showing you exactly what I see. Note that although I have properly installed the Attachments 2.1 extension, "Attachment Settings" is no where to be found!

    Please help!
  • Just a shot in the dark: Have you tried to deactivate all the extensions but the Attachment-extension, to see if the Attachment settings is still gone?
  • I've a similar problem to JDW

    I've created the folders like described and so the system looks like:

    root:
    ->
    ajax
    conf
    extensions
    uploads
    .
    .
    .

    Inside uplodas, there is only the AccountPicutre folder (btw: this ext. works).

    The setting of the attachments is:
    "http://my-url.com/Forum/uploads/%userid%/"

    But whenever I want to attach a File, I get:
    An error occured while creating a new attachment folder. Check your upload path permissions

    Although the uploads folder has chmod 777 permission.

    Need help,

    Richard
  • KimC, thanks for the reply.

    I actually have been advised to do a reinstall of Vanilla. And I attempted such yesterday as posted here. But as you can read in that post, I cannot for the life of me figure out how to do get past that error and do a clean install!

    To my joy, I awoke this morning to see a post from "Mark" in that thread (I had long hoped Mark would put a reply there). But my jaw hit the floor when I read the content of his post, seeing that it had nothing at all to do with the pain and suffering I had posted in that thread over the past several days (pain and suffering which now comprises the bulk of that thread).

    Suffice it to say, I am greatly disheartened about the feasibility of getting Vanilla to work at all for me at this stage. If even the author of Vanilla won't comment about fundamental problems with Vanilla, I'm not sure there is much more I can do -- I'm swimming upstream right now.

    UPDATE: I started a new discussion here to see if more people would spot it and offer their thoughts. I can only hope they will.
  • Rysk, looks like you have the wrong path for your attachments folder. You shouldn't have your URL, but the actual filesystem path for your webserver. Yours will be different from mine, but mine looks like this:/home/.frac/exhibitq_com/exhibitq.com/talk/uploads/%year%/%month%/
«134567
Sign In or Register to comment.