Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Invite-Only System

This discussion is related to the Invite-Only System addon.
edited November 2007 in Vanilla 1.0 Help
Invite-Only System
«13

Comments

  • Uploaded version 0.3.0.a of Invite-Only System.
  • I think this is has a very good concept for like a private forum site. My developing site isn't private but now I want to make it private so I can use this.
  • I saw that one of the links in this AddOn wasn't using the GetUrl() function properly to make the link completely Friendly URL compliant. It is a quick change. This fixes the Invitations link under Account Options when on the Account page:

    Find (around line 292):
    $Panel->AddListItem($AccountOptions, $Context->GetDefinition('InvitationSystem_Link'), GetUrl($Context->Configuration, 'account.php', '', '', '', '', 'u='. ForceIncomingInt('u', $Context->Session->UserID) . '&PostBackAction=Sesame'));
    Change to:
    $Panel->AddListItem($AccountOptions, $Context->GetDefinition('InvitationSystem_Link'), GetUrl($Context->Configuration, 'account.php', '', 'u', ForceIncomingInt('u', $Context->Session->UserID), '', 'PostBackAction=Sesame'));
  • Possible to set which user groups can have invitations? :D Whoops, just studied the plugin more carefully. Got it now, thanks!
  • Where should the invitation Form appear? I copied the files in /extensions and activated it but there doesnt appear a link or something on the hole forum :/

    Invited by: and Invitations sent: stuff appears, only that link is missing
  • You need to go in the registration setting page to activate it and add the permission to send invitation to the role you want to allow to send invitation. Read the readme file for details.

    After you can sent invitation on your account page.
  • Errors... big error...

    For some reason this thing went bonkers! It messed up my settings.php and reset the fields in the admin page. I reset it and now it gives me this;

    A fatal, non-recoverable error has occurred
    Technical information (for support personel):

    Error Message
    Could not create the Invitation Table
    Affected Elements
    undefined.Invite System Installer();

    The error occurred on or near: Duplicate column name 'InvitationID'

    For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs

    -----

    So any suggestions? Should I just disable the invite system and delete the invite database and redo it?
  • Add "$Configuration['INVITATION_SYSTEM_FIRST_ACTIVATION'] = 1;" in conf/settings.php

    The installer should check the column exist before trying to install it. I have to add that.
  • Ummm.... thats already in my settings.php file....

    Okay, got it working now. Had to delete the database entries in User database and the complete Invitations database.
  • Sorry, it was $Configuration['INVITATION_SYSTEM_FIRST_ACTIVATION'] that needed to be added (I updated the previous post).
  • Any chance of getting an updated release with this fix as well?
  • Uploaded version 0.3.0.b of Invite-Only System with the above fix.
  • Uploaded version 0.3.1 of Invite-Only System.
  • Change log:
    + 0.3.1:
    - Fixed installer bug when the invitation fields in the user table exist already.
    - More friendly link (thanks to gpreston).
  • Nice one. Somehow I managed to ingore this add-on so far.
  • Woo, good deal! Thanks a lot for the great work on this addon :)
  • hello,

    i get this error after i install the extension...
    Could not setup the table or the settings for the Invitation System extension. Please check your permissions.
    the read/write ftp settings are all ok and readable so far.

    any hints?
    thanks in advance
  • You can try to drop the invitation table and the three invitation fields in the user table; remove the invitation settings from conf/settings.php; and then retry to install.
  • hm, still got the same error message, i also 777' all extension files and folders, but still no success so far.

    one more hint? :D


    thanks
  • Uploaded version 0.3.1 of Invite-Only System.
«13
Sign In or Register to comment.