Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • Options
    Uploaded version 2.0 of Chronological.
  • Options
    Thanks to you.
    Whoops. but I got this error message when I installed Chronological 2.0.

    Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /home/hosting_users/digitypoweb/www/forum/extensions/Chronological/default.php on line 63

    so I removed this add-on, then it became to mass up on my Vinilla.

    like this.

    Warning: main(/home/hosting_users/digitypoweb/www/forum/extensions/Chronological/default.php) [function.main]: failed to open stream: No such file or directory in /home/hosting_users/digitypoweb/www/forum/conf/extensions.php on line 6

    Warning: main(/home/hosting_users/digitypoweb/www/forum/extensions/Chronological/default.php) [function.main]: failed to open stream: No such file or directory in /home/hosting_users/digitypoweb/www/forum/conf/extensions.php on line 6

    Warning: main() [function.include]: Failed opening '/home/hosting_users/digitypoweb/www/forum/extensions/Chronological/default.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/hosting_users/digitypoweb/www/forum/conf/extensions.php on line 6

    this error message shows every single pages on the top of my forum badly.
    so I removed the line 6 from conf/extension.php. then it works as ususal.

    would you check your add-on Chronological 2.0 please? I really want to use Chronological on my forum. ^^
  • Options
    Uploaded version 2.1 of Chronological.
  • Options
    I was using a foreach loop in a way that only works in PHP5. This one should work for you.
  • Options
    Thank you very much for your help.
    It fixed. no more error. :) but still it didn't work order change. it is same. I mean nothing happened even I activated Chronological add-on from extensions menu. :(

    one more thing, I would like to ask you where is the tick box as you show a picture on the top of this topic. I guess it seems like I need to activate like that. however I couldn't find that tick box.

    thanks a lot
  • Options
    That tick box needs to be marked for every category you want in this order, and you can find it under the settings tab, then the categories option on the left. You'll have to edit each category and it will be on the bottom of the category options.
  • Options
    @Wallphone I have check it in Categories option page and found nothing?! no tick box

    No Tick Box

    PHP Version 4.4.7
    Vanilla 1.1.4
  • Options
    If you turn off category roles does it appear?
  • Options

    Nothing appear

  • Options
    I'm having the same problem with the checkbox not appearing. It worked a while ago, and I just noticed that it's not now, but I can't tell what made the difference. Could it have anything to do with upgrading?
  • Options
    Its not an upgrade issue, I just tested Chronological with both 1.1.5 and 1.1.5a and they both work fine.

    The only things I can think of that would cause this are the extension itself getting corrupted, if you are using a custom theme, particularly if it was written before 1.1.2, or some other extension may be messing with it. The only way to know which one is by turning them off one at a time until the checkbox to comes back. Then let me know, and I'll see how to fix it.
  • Options
    After messing with it a while, I see it's because of my custom theme. Once I switched to the default theme, it worked fine. I'm creating this theme myself, but it's just a slight variation of the default theme from the latest version of vanilla. How can I make it compatible?
  • Options
    Okay, I take that back. It has to do with the settings_category_edit.php file included with the CategoryRoles extension.
  • Options
    OK, what you & fatro will have to do is add the delegate to that file, it's one line of code at line 82, near the bottom, and then you should be set.

    //CategoryRole end $this->CallDelegate('PostRolesRender');
  • Options
    It's work!

    but I have an suggestion on Sticky posts, Should it still be on top of the list?

    Thanx anyway WallPhone :)
  • Options
    I really need the sticky posts to be on top.

    Is it possible? Where should I look at?

    Thank in advance
  • Options
    It should work that way for everyone... I'll get it fixed.
  • Options
    Is it fixed now?

    I badly need that feature :)
  • Options
    I've had the same problem and adding $this->CallDelegate('PostRolesRender'); didn't help either. However I was able to change the template, then activate Chronological and edit the discussions before finally re-activating CategoryRoles. I'd love to see this fixed though ! I'll think I'll cross-post this message there to try and get things moving on their side.
Sign In or Register to comment.