Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Comment Links

This discussion is related to the Comment Links addon.


  • Seems to work OK once only per comment?

    Posted: Monday, 5 March 2007 at 7:05PM (AEDT)

  • Comment Links # 1 (Comment Links # 2)

    The menu isin't popping up again once it already did? It should. (and does in FF, IE, O)

  • That is correct, in Safari.

    1. I click the menu, copy as text, (or do nothing) works fine.
    2. I click again ('cos I want HTML) nothing happens, not even a page refresh.

    It will work on the other comments but again, once only.
    And yes, Firefox is OK.

    I have CommentLinks 1.2 installed on my forum, it used to work but now has the symptoms described above with Vanilla 1.1

    Posted: Tuesday, 6 March 2007 at 8:07AM (AEDT)

  • This add-on breaks UserInfoTooltip ... I have no idea wether this is a known issue. I would like to be able to use both.
  • I tried unsucessfully to reproduce Wanderer's error then realized I need to update to 1.1.

    As far as UserInfo Tooltip, I can confirm CommentLinks breaks it, but I don't see any obvious conflicts. Will look into these bugs.
  • Just installed this nice extension. Thank you!

    One thing: Shouldn't it say 'Click to copy...' instead of 'Double click to copy...'?
  • I needed a way to hint that you can double-click the numbered link to copy the URL in whatever format was last used, rather than clicking then clicking the menu item. The tooltip seemed the best way to do that.

    Its probably bad form to put shortcut instructions in a tooltip rather than the intended traditional label... but I can't think of a better way. Double-clicking on the web is not very intuitive.
  • I didn't get this, your right. I changed it at my forum to:
    $Context->SetDefinition('CommentLinks_DblClk', 'Click to select link format or double click to copy as current format (//1)');
  • Simple, yet effective :)

    Found a typo on the extensions page - 'copy to cipboard'

    And for some reason 1.3.1 doesn't display the menu in my test forum :( Immediately after I click the link, I get the following error in FireBug's error console:FormatType.toLowerCase is not a function Line 15

    Just to make sure, I disabled the extension, downloaded a fresh copy, uploaded it and enabled the fresh one.
  • Tex: I like that text much better, much clearer.
    Stash: Good find, it seems there is a conflict with JQ ThickBox. It strikes me as really odd, since .toLowerCase() is a built-in javascript function.
  • /me wishes he'd kept his mouth shut now...

    Is this something I've got to get fixed? Do you know exactly what is clashing and how?
  • No worries. I think its a problem on my side, since your JS appears to be standard thickbox code.

    All I know at this point is that the problem appears when thickbox.js is included, that its not a duplicated variable name, and that I really hate obfuscated/compressed JS. :-)

    No time right now to look much deeper into this, but if/when I find the conflict I will let you know.
  • Thanks WallPhone :) When you have time, it might be worth posting something in the Nabble jQuery forum as they are a pretty knowledgeable lot.

    Also, I'm going to ensure that I release the uncompressed JS code with the next release of JQThickbox, just for this reason - apologies.
  • Uploaded version 1.3.2 of Comment Links.
  • This update should fix any issues you may have with comment type formatters disappearing from the comments form. It also has an attempted fix for a Safari bug that keeps the menu from appearing a second time once it has been opened and closed.

    This doesn't fix the JQ Thickbox or Userinfo Tooltip conflicts that I am still researching.

    [-Stash-]: I am all for saving bandwidth, storage, and electricity, as long as uncompressed versions are easily obtained, so I wouldn't worry about releasing it uncompressed.
  • Uploaded version 1.3.2 of Comment Links.
  • mattmatt ✭✭
    This is incompatible with Dplayer.

    I'm not sure which is breaking which at the moment.
  • MarkMark Vanilla Staff
    I just want to say that this extension is the bomb. I use it constantly.
  • I just installed version 1.3.2. The Safari problem that allows only one view of the menu is still a problem (I tested in Safari 2.0.4).

    Also, I only get one option in my "Copy URL as" menu: text. No HTML option or anything else. I confirmed this problem in Firefox 2.x (Mac). I didn't see anything about this in default.php, so I'm not sure what the problem is here.

    Wanderer, you were really able to see an HTML option?
  • I've got a 1.4 update with a few cobwebs left to clean out that fixes compatibility with some prototype libraries, DPlayer, code prettify and UserInfoTooltip.

    If you have the HTML (or any other) formatter installed, those options should automatically appear in the menu. For example, my site has text, HTML and Markdown options.

    With no mac anywhere that I can get my hands on, I am really working in the dark when it comes to Safari. Unfortunately it works fine in Konqueror or that bug would have been solved by now.
  • Fatal error: Cannot redeclare commentlinks_addlink() (previously declared in forum/extensions/ReportPost/default.php:18) in /forum/extensions/CommentLinks/default.php on line 76

    Posted: Monday, 9 April 2007 at 9:16AM

  • heheheh
    2 extensions using same namespace
  • Wallphone, thanks for the reply.

    I have the latest versions (as of this writing) of HTMLformatter and ExtendedTextFormatter installed and enabled. I have confirmed that both extensions work fine to format text in my forum. And yet, I wasn't seeing the "HTML" option on my Mac at home. I say "was" because on my Mac here at work now, I see both "text" and "HTML" options. Its odd. Because this is the same exact Mac I use at home, with the same 10.4.9 OS version and the same version of Safari (and Firefox). Perhaps I just need to restart my Mac at home, which I will try later this evening.
  • You know, that just had to happen while Mini was on vacation.

    Just for the record, I had that function name first!
  • I renamed that function and it worked but still the problem persists in Safari where the menu only works once for each comment.

    Is something not closed, finalised, flushed?
    Maybe it's a Flash issue.

    Posted: Monday, 9 April 2007 at 1:44PM

  • Hi, Code Prettify don't work after enable Comment links, I guess it may be a prototype problems (Prettify is use prototype too).
    Is that right? :P
  • Actually, CommentLinks uses the body tag attribute onload="" to save some values into javascript variables, and Code Prettify attaches to the onload event with Javascript--like a good script should.

    If you remove the code from CommentLinks that toys with Body->Attributes, and replace it with a $Head->AddString similar to how Prettify does, then they will play nice together.

    I will plan on getting these both updated this weekend.
  • Man I didnt realise I hadnt changed the namespace references...
    Would someone be so kind as to remind me to do that when I can keep my eyes open for longer than a few minutes at a time?
  • It does not seem to work with issue-tracker...
Sign In or Register to comment.