Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Auto Hide

edited August 2007 in Vanilla 1.0 Help
Auto Hide


  • Options
    MarkMark Vanilla Staff
    This sounds like an awesome extension :)
  • Options
    Thanks. :)

    I've had a number of forum admins tell me that it's easier to catch spammers by holding the first post than with the various registration-stage measures. Figured I'd test that theory.
  • Options
    I want to auto-hide 'guest' posts. But, I'm unable to assign the 'autohide' setting for unauthenticated. Any ideas as to how I can bypass this problem? edit - I've got the following error coming up at the top of the page when on page: /forums/extension/?PostBackAction=AutoHideList Warning: Division by zero in /home/.pilar/xxxxxxx/ on line 95
  • Options
    I found that error myself just a couple days ago, and will put up the fix soon. :) (It's just a rendering issue -- nothing to worry about. That error pops up either when there are zero discussions to screen, or zero comments.)
  • Options
    Yep that's the one. Also I'm following the uninstall steps:

    1. Edit the file appg/init_ajax.php, uncommenting the following line of code:

    // include($Configuration['APPLICATION_PATH'].'conf/extensions.php');

    2. In Vanilla, go to Settings->Extensions, and disable Auto Hide. (The previous
    step ensured that the cleanup delegate will run.)

    3. Comment out the same line in appg/init_ajax.php to restore its previous state.

    Can you expand slightly on the 3rd step please. I'm not understanding. Comment out step #1 again? :S
  • Options
    Yes, it's saying to comment the same line out again, in order to restore Vanilla to its initial state (i.e. the '//' you removed in the first step, put it back in). :)

    As for the guest thing, I'm assuming you're using the guest post add-on? If so, just change the role of the guest account to one that is auto-hidden. The guest won't get the notice that their posts are hidden (unfortunately), but the hiding itself will work.
  • Options
    Done, thanks :). My eyes were just playing up as usual.
  • Options
    Uploaded version 0.1.1 of Auto Hide.
  • Options
    I've fixed the bug mentioned above, where the mod page was getting divide-by-zero errors.
  • Options
    I am having trouble administering the auto hidden stuff. That is, I have the link that tells me that there are comments hidden but when I click onto it I get 'No results could be found'. So at the moment the comments cannot be approved at all. It is a new vanilla install on a php5 server. Please help if you can Cheers Darren
  • Options
    It's either a preference or setting issue (or both). To view the mod list, your role has to have permission to view deleted items, and in your preferences, the checkboxes for viewing deleted discussions and comments need to be checked.

    I've tried to capture this and other quirks in the readme. You might want to check it out.
  • Options
    I'm seeing the same issue as karmabunny.

    When I'm logged in as an Administrator and go to a discussion page, I'm seeing "Auto-hiding is active for your user group".

    I'm a little confused by the 2 things you say need to be checked. Are each of these exclusive of the Roles & Permissions abilities? When I go to the Roles & Permissions for Administrator, all the checkboxes are checked, including "Deleted discussions visible" and "Deleted comments visible".

    Is the "your role has to have permission to view deleted items" setting somewhere else? Sorry in advance if I've missed something outlandishly simple.
  • Options
    There's two parts to viewing deleted items: the permission to do so (which you appear to have taken care of), and the preference to do so, the latter of which you set in your account preferences. This is just how Vanilla works -- my mod didn't change any of that.

    It sounds like you've got the wrong Auto-hide permissions set, though. For administrator accounts, you'll want to check the permission to moderate auto-hidden items, and make sure the other one (auto-hide comments/discussions) is unchecked.

    (Sorry that I haven't been visiting this forum as much as I should ^^;; )
  • Options
    For those having trouble viewing the comments on the Auto Hide moderation list (specifically if you can see the moderation list, but you can not see the individual comments when you click through to its discussion):

    If you have the Hidden Text add-on enabled, you might have the same issue as me. I work around it by checking the "Disable hide hidden text" in my account preferences, whenever I want to work with the hidden comments.
  • Options
    Probably the last update to this topic for a while:

    AFAIK, Hidden Text isn't causing problems for Auto Hide anymore. Also, Auto Hide is now part of the vanilla-friends project.
  • Options
    I've installed it and it seems to work, except that I can't see any way to get the auto-deleted comments to become undeleted.

    When the admin user views the moderation page, the auto-deleted discussions and comments appear.
    The individual discussion pages have an 'undelete discussion' link which works to undelete the discussion, but the auto-deleted comments are still deleted.
    If the admin user goes to the moderation page, the auto-deleted comments are still listed. When you click on the comment link, it displays the comment page (with the 'deleted' visual formatting) but there is no 'undelete comment' link, just a 'delete discussion' link.
    As far as I can see, all the relevant 'comment'-related settings are ticked...
Sign In or Register to comment.