Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Upgrading from version before RC1

vekiveki New
edited July 2010 in Vanilla 2.0 - 2.8
Hi guys,

I am still running version from GitHub that was there few days before RC1. I think it was in the beginning of may. I still have "garden" folder and not "dashboard" in my admin area :)

So, what is the best way for me to upgrade?

1. to install RC1 then RC2.... and finally V2 or
2. directly try to install V2?


  • Options
    TimTim Operations Vanilla Staff
    You can probably go directly to V2 as long as you run the database update scripts (/utility/structure).

    The only problem you'll encounter is that you cannot simply overwrite your current folder with V2 files. We made some drastic structure changes and you'll have old files left over which will conflict.

    I suggest backing up your install's files, and the database, then deleting your entire installs (possibly saving your config.php) and unzipping V2 to the now-empty folder (then copy your config.php back in).

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    TimTim Operations Vanilla Staff
    Important: When upgrading from a pre-RC2 install, always delete all existing files... simply overwriting will give you errors.

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    Tim, thanks for the very fast answer.

    Just one more question. Just say yes :)

    When I am doing a database upgrade? After I copied new files to my "forum" folder?
  • Options
    vekiveki New
    edited July 2010
    Problems with SingleSignOn. Here is how my upgrade process is going on

    1. First I had a problem with Url rewriting. The bug was:
    Unknown column 'd.CountBookmarks' in 'field list'
    I found solution here>'d.CountBookmarks'+in+'field+list'#issue/426

    So I am finding a way to upgrade my database on this address:

    2. Now I am fighting with this bug
    Tried to load authenticator 'handshake' which was not yet registered.
    in library/core/class.auth.php on the line
    64: if (!in_array($AuthenticationSchemeAlias, $this->_AuthenticationSchemes)) { 65: throw new Exception("Tried to load authenticator '{$AuthenticationSchemeAlias}' which was not yet registered."); 66: }

    I am pretty sure that SingleSignOn is causing this error:

    Here I my steps:
    1. Deleted all files
    2. Copied new files
    3. With new config.php, it looks I am nog sign in, and it redirects me to login page (there i am logged in)
    4. Now I am experimenting with mix of old and new config.php

    Soon I am writting again
  • Options
    TimTim Operations Vanilla Staff
    What singlesignon are you using? ProxyConnect?

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    vekiveki New
    edited July 2010
    @Tim, I was using the old version. Now I installed new version.

    Here I have two VERY BIG problems:

    1. How can I workout about this
    A. When DEBUG is set to FALSE I have "Page is not found"
    B. With DEBUG on mode, I get this error:

    2. I have the bug with new ProxyConnect

    Could not find a '/home/trcanje/public_html/forum/plugins/ProxyConnect/views/proxyconnect.php' view for the 'settings' controller in the 'dashboard' application.

    665: if ($ViewPath === FALSE) 666: trigger_error(ErrorMessage("Could not find a '$View' view for the '$ControllerName' controller in the '$ApplicationFolder' application.", $this->ClassName, 'FetchViewLocation'), E_USER_ERROR);
  • Options

    Ok.. I succesfully managed to ugprade from a version that was before RC1 to V2. Gratulation to team and to me :))

    Here are the steps for people that will be in the same situation as me (probably nobody)

    1. delete old files (or just rename your xxx/forum folder to xxx/forumOld
    2. upload new files to xxx/forum
    3. if you see problems here google for it. problably you will have to mix .httpacces rules and config file. Here is solution'd.CountBookmarks'+in+'field+list'#issue/426
    4. then you will go to
    5. here you see install prompt for new forum. that you dont want to do.
    6. thats because you didnt set your conf/config.php. just copy the old one, and delete all lines for authentication (if you are using OLD single sign on for wordpress)
    7. you will have to login once more now
    8. now you go to step 4.
    9. upgrade database by just clicking button on the end.
    10. hola... you can istanll proxy connect.. and there you click settings and get new error
    Could not find a '/home/trcanje/public_html/forum/plugins/ProxyConnect/views/proxyconnect.php' view for the 'settings' controller in the 'dashboard' application.

    countinue to work around


    Great job, everybody.

Sign In or Register to comment.