Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Edit user photo button missing since RC2

edited July 2010 in Vanilla 2.0 - 2.8
I have been keeping up with all the latest RC's, and somewhere in RC 2 there must have been a change to the way photos are managed, because the button to add or change your photo is missing from the side menu of the profile.

I thought maybe it was just a bug that would be worked out in later RC's, but now the official release is out, and I still have this problem.

I have tried deleting all files, (except the 'theme' and 'plugins' folders), dropping and recreating the database, and setting up the site fresh several times, and I still have this problem.

Everything else seems to be working perfectly, that is, except for my own sloppy-coded plugins, but I'm working on that. :)


  • Options
    The options are still there in the profile options. The links for the photo are:

    Change My Picture
    Edit My Thumbnail
    Remove My Picture

    They are at the top of the menu.
  • Options
    Actually, they're not...

    That is what I mean. These links are missing for me for some reason. The links for Account, Password, and Preferences are there, (and a few plugin links) but not for the photo any more.

    It has been this way for me since about RC2, and I have dropped the entire database and erased everything but my theme and plugins and still cannot get it to appear...

    Seems I'm the only one having this problem, what could it be? o.O
  • Options
    sadece deneme yazısıdır
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Just to troubleshoot, can you switch your theme back to the default and see if the the links appear.
  • Options
    No, I switched it to the default theme, and they still did not appear :(

    I have also been using the 'Gravatar' plugin as well, although disabling it doesn't help... I'm not sure what else to try :d
  • Options
    In my case, i just needed the GD package for PHP, just do...

    $ apt-get install php5-gd
    $ /etc/init.d/apache2 reload

    and "Change My Picture" is back.
  • Options
    ah, of course, makes sense.

    Yes, this was the answer to my problem. Thanks much.

    It should probably be noted that this is a dependency.
  • Options
    edited July 2010
    :P rating system confuses me ^^ (you can erase this)
Sign In or Register to comment.