Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

picture upload not working

purebloodpureblood New
edited July 2010 in Vanilla 2.0 - 2.8
First off, thank you for the current version. I checked several previous ones but the current one looks really promising.

I try to upload a photo to my profile but the picture will not find its way onto my webspace.
The database entry and everything is there after my uploading but the picture is broken because vanilla cannot find an image at the given url.
So somehow no error appears whatsoever but still the picture is not there.

It is definatly looking like a permission login but I already did a "sudo chmod -R 777 upload" and everything looks fine there.
Any ideas where I should take a look?

btw: my picture file is ok as well, I even tried uploading it in the hosted version which was working as expected.


  • Options
    just uploaded the same file here into my profile just fine. so it is not the file that is making the problem and it is not the permissions.

    I kinda think there must be a wrong php temp configuration in vanilla that is not compliant to my server paths....
  • Options
    There is no error message appearing as well. I would expect that after checking the uploadimage.php

    $Ex = T('The file failed to upload.');
    case 6:
    $Ex = T('The temporary upload folder has not been configured.');
    case 7:
    $Ex = T('Failed to write the file to disk.');
    case 8:
    $Ex = T('The upload was stopped by extension.');
  • Options
    but again:
    IF an error occured then vanilla would not make a database entry for the picture, would it?
  • Options
    I cannot believe this would be a hard one for any developer...
    guys come on!

    did I miss to provide some important information, let me know.
    must be possible to solve
  • Options
  • Options
    purebloodpureblood New
    edited August 2010
    I know that being patient is a virtue and that there are surely more pressing matters at hand but if this is as far as the support will get in here, then it is not really of any use.

    I mean, please hint me in the right direction if I missed anything in my report....
  • Options
    Just out of pure boredom I tried the new 2.0.1 version...
    and there you go here it is working.

    so lets forget about the old one, there must have been a bug, that is gone in the current one.
Sign In or Register to comment.