Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla exporter v1.1 has been released (with phpbb3 support)

ToddTodd Chief Product Officer Vanilla Staff
edited July 2010 in Vanilla 2.0 - 2.8
Hi guys. I just pushed v1.1 of the Vanilla exporter live which included phpbb3 support. You can find it here


  • Options
    When I click on the begin export button is it supposed to open a download dialogue? because all that happens for me is I get a new page in my browser with a huge amount of text containing the contents of my vanilla 1 database. I tried running it in both windows and firefox on both windows and linux with the same results. Because none of my browsers produced anything downloadable I figured it might be my server config, but I couldn't find anything there and I do have another site on the same server that has downloadable content available via php scripts, that's not to say it isn't the server config though I just can't find anything unusual.

    So I gave up on the download side, and I tried saving the contents of that page as a .txt file directly from the browser, and copy and pasting the contents into various text editors on both windows and linux and saving it (nano and vi really didn't like this CPU hit 100% for about 20 minutes). After a lot of messing around, and manually editing the format of the text I managed to get something that vanilla2 would import. Unfortunately it's mostly gibberish. I only have a small private site with 22 registered users but the import script managed to create 3724 users most with a blank username or a username of 0, 1, etc. No discussions have been migrated, all my categories are gone, all rolls and permissions are gone.

    I've been trying to get this to work for 2 days now (originally with version 1.01 of the script exact same result), and I have to say I'm starting to go a bit loopy trying to figure it out. I'm sure it's probably something simple, but I just can't figure it out. Any idea where I'm going wrong, or what I need to do?
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    If you put the script in a writable folder then you will the option to save it to your server. Try that.

    You shouldn't be editing the file though.
  • Options

    You sir are a genius!

    Worked perfectly first time, created a nice downloadable file for me, so I downloaded it and renamed it (it didn't like the format of named file export_vanilla_2010-07-31_165217.txt.gz so I gunzipped it and renamed it export.txt) and it worked first time.

    Many many thanks, my wife will be pleased that I won't be stuck looking at the damned computer for much more of the weekend :)
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    That's good to hear. I'm actually surprised you had so many problems an I'd like to get to the bottom of it. Are you saying that you tried this with Firefox on Windows and Linux? Which OS didn't like the filename? Was that on the import or what?
  • Options
    The import was initiated on windows 7 with firefox, the server is running apache 2.2 on ubuntu 10.04. It may not have been the filename it didn't like I just assumed it was. What I did was gunzip and rename the file at the same time, and that worked, which action was the one that made the difference I don't know.

    If you want to try and get to root of the problems I was having it's very easy to reproduce, feel free to send me a PM and I can give you the details of the site (mysql passwords are very easily changed) so you can see it for yourself.
Sign In or Register to comment.