Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Bonk. Something funky happened. Vanilla Default MEGA theme

This discussion is related to the Vanilla Default addon.
fr1dayfr1day New
edited August 2010 in Vanilla 2.0 - 2.8
Very nice theme pack, thank you. My only problem is whenever I apply a new style I get the "Bonk Something funky happened. Please bear with us while we iron out the kinks." Error. The style still applies okay, I just have to reload the home page to see it applied so it's not a big problem.

The only unusual thing I'm doing is running the site via https so maybe it's something there?

Comments

  • This is also happening on my clean v2.01 installation with standard settings.
  • You just reminded me, I forgot to say that I'm also running 2.0.1 upgraded from 2.0.
  • same for me on 2.0 with vanilla defaut mega theme
  • ToddTodd Chief Product Officer Vanilla Staff
    Can you change the following line in you /conf/config.php and paste the entire error here:
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';
  • Me too, but it is good working
  • That's useful to know... output below. the file mentioned doesn't exist, but write access is enabled on the directory so it's not that...

    Unable to write to config file '/var/www/forum/conf/locale-en-CA.php' when saving.
    The error occurred on or near: /var/www/forum/library/core/class.configuration.php

    372: if ($File == '')

    373: trigger_error(ErrorMessage('You must specify a file path to be saved.', 'Configuration', 'Save'), E_USER_ERROR);

    374:

    375: if (!is_writable($File))

    376: throw new Exception(sprintf(T("Unable to write to config file '%s' when saving."),$File));

    377:

    378: if($Group == '')

    379: $Group = $this->CurrentGroup;

    380:

    Backtrace:

    [/var/www/forum/library/core/class.locale.php:87] Gdn_Configuration->Save();

    [/var/www/forum/applications/dashboard/controllers/class.settingscontroller.php:538] Gdn_Locale->SaveTranslations();

    [/var/www/forum/library/core/class.dispatcher.php:270] SettingsController->ThemeOptions();

    [/var/www/forum/index.php:38] Gdn_Dispatcher->Dispatch();

  • same error to me
  • ToddTodd Chief Product Officer Vanilla Staff
    I've made some changes so you will see a better error message in a future version, but the thing to do now is to set the permissions on your /conf/locale-en-CA.php file so it is writable by the application (or everyone).
  • That file doesn't exist for me. It's not part of the release (both 2.0 and 2.0.1), and the folder is writeable so can be created by the app if necessary. I do have a locale.php file though don't know if it's related, or relevant?
  • ToddTodd Chief Product Officer Vanilla Staff
    Okay, I just reproduced the bug. You can work around this for now by creating an empty text file for /conf/locale-en-CA.php and giving it the correct permissions.
  • Just tested and that works fine, thanks Todd.
  • it seems that if you don't copy cache\smarty\cache and cache\smarty\compile back after an upgrade, you'll get this error. you can create these directories to get around the problem.

    however, does anyone know what the files in \compile do?
Sign In or Register to comment.