Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[ProxyConnect] Compatibility issues

This discussion is related to the Vanilla Proxyconnect addon.
edited August 2010 in Vanilla 2.0 - 2.8
On a clean installation of v2.01, I receive an error message when enabling ProxyConnect:

Fatal error: Class Gdn_ProxyAuthenticator contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Gdn_IHandshake::GetUserEmailFromHandshake) in D:\xampp\htdocs\dbtest\community\plugins\ProxyConnect\class.proxyauthenticator.php on line 332

My forum remains inaccessible as long as I manually remove everything related to the plugin and $Configuration['Garden']['Authenticator'] from my config.php.


  • I'm having the same problem, and I did the same thing. Then I logged out and I can't get back in.
  • TimTim Operations Vanilla Staff
    I realized sometime last week that there were several issues with ProxyConnect and indeed with all authenticators, that would present themselves down the road. I started working on solutions for these problems and they kind of snowballed into a bigger update than I previously thought. As a result, I missed the 2.0.1 deploy date, so I'll be releasing a new ProxyConnect for 2.0.2 (and first for for 2.0.2a - unstable) shortly.

    Sorry for the inconvenience, but I think you'll like the changes :)

    Vanilla Forums COO [GitHub, Twitter,]

  • edited August 2010
    I spent several hours to make this work without success. I was able to follow until Authenticate Url. However, I couldn't proceed in the last section (Finishing Touches) of your documentation. The instruction says
    'insert into GDN_UserAuthentication (UniqueID, UserID) values ($YourAdminUsersUniqueID, 1);'
    However, UniqueID column doesn't exists in the GDN_UserAuthentication table. Rather two columns-ForeignUserKey and ProviderKey-- exists along with UserID column in the table. The documentation seems to be outdated. I am looking at the white-screen-of-death now.
  • eleitheleith New
    edited August 2010
    for anyone just wanting to get 2.0.1 working with proxyconnector 1.4 look for this line in plugins/ProxyConnect/class.proxyauthenticator.php
       public function GetTokenKeyFromHandshake($Handshake) {
    return ''; // this authenticator doesnt use tokens
    and add the following snippet right after it (do not replace it, just append it):
       public function GetUserEmailFromHandshake($Handshake) {
    return ArrayValue('Email', $Handshake, FALSE);
  • Tim,

    Thanks for the update. Any idea of a time frame for these updates? I am debating whether or not I should write a custom authenticator for our project or not.

    Also, when using ProxyConnect, is there any way to skip the "Give me a new account"/"Link My Existing Account" screen? We just need our existing users to have a new account generated as soon as they are authenticated by ProxyConnect.
  • TimTim Operations Vanilla Staff
    @zonymous I'm hoping for this afternoon or monday. I'll be including that feature in the new version.

    @eleith thankyou

    Vanilla Forums COO [GitHub, Twitter,]

  • @Tim Thanks so much for the update.
  • @Tim. Will you also update the Finishing Touches section on Wiki where it has the wrong table columns? Thanks!
  • Thanks @Tim, looking forward to any updates...
  • Any news on this?
  • TimTim Operations Vanilla Staff
    edited August 2010
    I just uploaded version 1.6 of ProxyConnect.
    This version contains quite a few updates and changes, and is unfortunately not backwards compatible with 2.0.1.

    We'll be making 2.0.2 available shortly, but I've left the version requirement 2.0.2a on the plugin so that you can use it with the current unstable code at

    New config settings:
    Garden.Authenticator.SyncScreen - TRUE by default, this setting allows you to disable the "Link Accounts" screen during new SSO user signup.

    Garden.Authenticators.proxy.AuthField - This setting allows forum administrators to decide which remote field should be considered the UserKey when creating a new user via SSO. Defaults to 'UniqueID'.

    The biggest change in this release and with 2.0.2 in general is the consolidation of authenticator configuration in a single menu item on the dashboard. Settings can be affected via the Users > Authentication submenu.

    P.S. a new dashboard theme is coming and will improve the look and feel of this section.

    Vanilla Forums COO [GitHub, Twitter,]

  • @Tim Sounds promising, but how exactly is this supposed to work? As soon as I choose an option from the Authenticator's select box, an ajax-loader appears and seems to be running forever, but there are no configurable options. When I just click 'activate', the corresponding Authenticator shows up as 'Current Authenticator', but this doesn't seem to make a difference regarding login or registration.
  • TimTim Operations Vanilla Staff
    Are you running 2.0.2?

    Vanilla Forums COO [GitHub, Twitter,]

  • TimTim Operations Vanilla Staff
    And if so, have you hard-refreshed?

    Vanilla Forums COO [GitHub, Twitter,]

  • Just pulled from github, v2.02a. Anyway, just noticed that V2.02 has been released shortly before and as far as I can see, there has been another update to the add-on. I'll just do a quick re-install and check if it is working now.
  • TimTim Operations Vanilla Staff
    I found the problem. I'll fix it momentarily. Sorry for the inconvenience!

    Vanilla Forums COO [GitHub, Twitter,]

  • No trouble whatsoever...
  • TimTim Operations Vanilla Staff
    ProxyConnect 1.6 + Vanilla 2.0.3

    Works for me. How about you?

    Vanilla Forums COO [GitHub, Twitter,]

  • Thanks for your quick response, @Tim! Works nearly perfect up to now (not to become too enthusiastic ;)

    Will do some more testing...
  • Just because I'm a tad curious:
    I found the SyncScreen setting in config-defaults, but where is the AuthField setting?
Sign In or Register to comment.