Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't get Conversations to work in 2.0.3

edited August 2010 in Vanilla 2.0 - 2.8
I am having a problem in getting conversations to post in 2.0.3. When I hit "Start Conversation" the little activity indicator keeps advancing over and over but the conversation never really posts to the inbox. Any ideas?




  • ToddTodd Chief Product Officer Vanilla Staff
    Check your outgoing email settings. You may not have them configured and they could be timing out.
  • Ok,

    I think email is set up properly. What is strange is that I can send a message to a user via the "send a message" selection in the user panel of dashboard but when I try to start a discussion in the "inbox" it stalls. Aren't both of these conversations, the send user a message and the start discussions, or am I confused? The send user a message text does appear in the inbox but the start discussion feature in the inbox stalls. If that makes any sense.
  • DanDevineDanDevine
    edited August 2010

    I spent some more time on this. I added test users using one of my other email addresses and did receive an approval email to that test address if I approve it, nothing if I decline so I assume the email is set up properly. I, as admin, have never received any email, no notifications of posts like I was getting in version 1.16. I do NOT receive an email to me notifying me of a new application for membership so I can pretty well say something is wrong with email to ME. I cannot start a new conversation using the start a new conversation button in the inbox but I can add to a conversation that I had started before I converted to version 2.0.3 just fine. I can edit my account by using the edit selection in the edit|delete section of the user panel but I can't edit my account when I use the Edit my Account selection under the left options panel of User, the window just keeps running but never saves the changes. Same behavior as the Start a Discussion window. Have to bail out by using the close window button. I have so far noticed no problems with starting a discussion, replying, editing or deleting discussions.

    I have done this testing using version 2.0.3, the default vanilla theme, and all plugins disabled. I have all the checkboxes checked in MY roles and permissions. Hope someone can shed a light on what is going on.

  • Same problem. I fill in the conversation form, hit the Start conversation button and nothing happens. Activity indicator just keeps going and going...
  • this is likely the same problem as with the setting popup boxes not closing properly.

    Try installing the latest version from github, this fixes the issue with the forms.
  • But, isn't 203 the latest version?
  • Yep! Your correct. edited the title and content of the original post. I can't really remember if it was working in 2.0.1 either but I did have some conversations in 2.0.1 so it must have been working for someone in 2.0.1. I think it is that popup box bug and like everyone else just hanging in there until 2.0.4 and hopefully a bunch of fixes to some of the problems.

  • 2.0.6 solved this problem.

    Thanks for the great update.
  • I hate to be the bring of bad news, but I am still getting this exact same issue with 2.0.9
    Did anyone ever work out what was causing it?
  • Just tried updating to 2.0.13 but this caused errors with the database update and still didnt fix this issue with the conversations not working
Sign In or Register to comment.