Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Parse error: syntax error, unexpected ',', expecting '(sitedirectory...bootstrap.php on line 64

edited August 2010 in Vanilla 2.0 - 2.8
I am getting this error when I navigate to the forum files that I have uploaded, does anyone know how to fix it? I had the forum working on a local mamp server but it doesnt seem to qwork on my heart internet hosting package (home pro). The package doesnt support 'overide all' so i am not sure how to fix this or get round it.

Any help would be appreciated.

Chris

Comments

  • Options
    I've got the same problem! I'm building a static wordpress site and using vanilla to host the forum. Anyway, if you hear anything let me know. You might try asking on the wordpress forum, they're knowledgeable and regularly reply. Mark
  • Options
    My problem is not wordpress related. I have contacted my hosting package and they are going to fix it, I will let you know when I have it working.
  • Options
    I also get this problem and i too use Heart Internet. Has any one fixed it?
  • Options
    TimTim Operations Vanilla Staff
    What version of PHP are you using?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    MarkMark Vanilla Staff
    I'd suggest you make sure that the bootstrap.php file was uploaded properly. FTP can fail sometimes, causing files to be incomplete and show parser errors like this. I've already had a few people report these types of problems since V2 came out.
  • Options
    edited August 2010
    im having the same issue:

    Parse error: syntax error, unexpected ',', expecting '(' in /home/sites/public_html/bootstrap.php on line 64

    on a completely different host....

    Sorry guys im a bit new to all this, any ideas?
  • Options
    TimTim Operations Vanilla Staff
    Try re-uploading the file to your host, it could have been corrupted during transfer.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    Hi all: I had this issue as well, that error string exactly.

    It was because I was using php4. My host allowed an insta-switch to php5. I did so, and the above error immediately went away and the installation worked.

    It's an issue with php4. You need to be on php5.
  • Options
    i know this is an old thread, but i ran into this issue as well and solved it by adding the following to the .htaccess file -
    AddHandler x-httpd-php5 .php AddHandler x-httpd-php .php4

    all better!
    also, i'm on godaddy. not sure if that matters.
Sign In or Register to comment.