Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My Invitation idles

I have a fresh install of Vanilla 2 on Cherokee which was seamless. But, it's ironic the feature that played a vital role in my choice of Vanilla is not working for me.

When I go to My Invitations, put in an email address, and then click "Invite", it just idles.
The animation icon never pauses to indicate any hangup, but I never get an error/confirmation message either. I put in one of my alternate emails, but nothing appears in the inbox or bulk.

I'm on Linode and have all the software requirements met for Vanilla 2. I've gone through Postfix tutorials and I've tried using my SMTP with Google Apps, but get the same problem.


  • Options
    I know nothing about a google App SMTP server, but if you've tried using postfix can I ask how postfix is configured (local delivery, remote delivery, authenticated or not etc)? Are there any entries in the postfix logs that might give an indication of what's happening?
  • Options
    This is the tutorial I followed to get php to send outgoing mail:

    Other than that, I'm new to configuring postfix (first time VPS, no pre-configured shared hosting). Using dpkg-reconfigure postfix, it is set to "Internet Site", then all the defaults afterwards.

    I've aptitude enough to look into what you are requesting, but generally it is starting to look like my issue is more related to my VPS setup than with Vanilla.

    I guess what I am looking for is what's the preferred requirements/software/etc. for Vanilla that's not exactly listed on the Installation page, particularly for the Outgoing Mail feature.
  • Options
    Hmm, this could be tricky to troubleshoot if you've no real experience with MTA's. First place I'd look is in the logs. I'm guessing it's ubuntu by the fact that you're using dpkg-reconfigure (not necessarily I know, I'm just taking a guess based on it's popularity), so have a look at /var/log/mail.log is your best bet. If possible tail that file while attempting to send a mail (tail -f /var/log/mail.log) and that will capture in real time anything the mail server is doing.

    Hopefully that will point to where the problem is, because without something to give an indication of what's going on it could be pretty much anything.
  • Options
    fr1dayfr1day New
    edited August 2010
    Baah you got in before me :D glad you're sorted anyway.

    [EDIT] Wait that was posted yesterday. How come I didn't see it before I replied. Ah well.
Sign In or Register to comment.