Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

import vanilla 1 to vanilla 2, format issue

edited August 2010 in Vanilla 2.0 - 2.8
hi, i followed the importing data instructions ( ) to upgrade from my vanilla 1 to vanilla 2.
But the interface of vanilla 2 says me the format is wrong.

my file name, made with the vanilla2export.php :

so i executed the SQL with phpmyadmin and it returned two errors
import.php: Missing parameter: import_type (FAQ 2.8)
import.php: Missing parameter: format (FAQ 2.8)

thanks for your help


  • Options
    You shouldn't have to go near phpmyadmin. If you get the export tool to create a file for you, then you browse to your forum, go to the Dashboard, and down near the bottom under Site Settings, click on 'Import'.

    In there you can upload the file created by vanilla2export.php, enter the admin username and password of the Vanilla 1 forum, and click Upload.
  • Options
    edited August 2010
    that is what i did.
    i tried this in the dashboard interface with the admin username and password of the old vanilla 1, but i have the error message:
    The import file is not in the correct format.
    I tried to rename the import file like this and upload for each of these:

    but it doesnt work, that is why i tried with the SQL console of phpmyadmin :/
  • Options
    A couple of things you could try. Firstly rename the file to export.txt.gz, if that doesn't work gunzip the file, and try using the uncompressed export.txt file (don't rename it as the .gz extension means the file has been compressed).

    Failing that make the directory the export script runs from writeable, that will give you an extra option to save the file directly to the server. Try the above two procedures with the file created directly on the server.
  • Options
    the uncompressed export.txt file worked very well :)
  • Options
    I was downloading the export using Lynx on the server.

    I found I had to remove some whitespace at the top of the txt file for Vanilla to accept it.
Sign In or Register to comment.