Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Search doesn't work

edited August 2010 in Vanilla 2.0 - 2.8
I just downloaded the latest 2.0.3 and the search doesn't seem to be working. It returns 0 results when I search for the keyword in the title. Am I missing something?

Comments

  • Options
    I could not get search to run on first go round either, what I had to do in order for it to work was to setup Mod_Rewrite or pretty urls. To do this open the config.php file and make sure that you have

    Edit /vanilla/conf/config.php

    to reflect

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    the second part is to make sure that you have the htaccess file in the root of your directory. This does come with the download of vanilla but sometimes does not make it into the actual directory, if it is there great, if not create a new file called .htaccess it will make an invisible file put this content in it.

    <IfModule mod_rewrite.c> RewriteEngine On # Certain hosts may require the following line. # If vanilla is going to be in a subfolder change this to /foldername # RewriteBase / RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L] </IfModule>

    Once I did this, I was able to use the search functionality, worked for me let me know how it goes!
  • Options
    TimTim Operations Vanilla Staff
    Seems like a number of features are being adversely affected when RewriteUrls are disabled. @Todd should look at this.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    hey guys. I already have all the steps that jbrown suggested. In fact, all that was already there with the installation. What else could be missing?
  • Options
    I resolved this issue by adding my sub dir in the config.php . The problem was that my install runs in a sub dir. Thanks again
  • Options
    @vincent2 - where did you add this in the config.php? It's obvious in the .htaccess, but not in config.
  • Options
    Edit /vanilla/conf/config.php
  • Options
    edited August 2010
    @vincent2 - what I meant is, what line did you add to config.php? I don't see any sections in the current file that seem to show a path that can be added or changed. My search still doesn't work (and yes, rewrite urls are enabled, and my .htaccess file has the subdirectory (/forum).
  • Options
    @mandel23 it is possible that it was not included in the config.php if it was not needed, this is the case with many configuration options if they were never changed from the default values.

    Look in the default.conf.php file, and copy settings over to your own config.php, and try adjusting them from there. The one line that immediately stuck out to me was:

    $Configuration['Garden']['Cookie']['Path'] = '/';
  • Options
    Thanks @zodiacdm. I think my issue was that there were not enough posts, as search is working now without any conf.php changes required.
Sign In or Register to comment.