Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Enabling Friendly URL's

edited August 2010 in Vanilla 2.0 - 2.8

I have Vanilla Forums now up and running at:

My friendly URL's are not working though. I notice that in the config-defaults.php file there is a setting for it.

$Configuration['Garden']['RewriteUrls'] = FALSE;

If I change that nothing happens, and if I make a config.php file (removing -defaults) it wants to reinstall the whole software.

Is there a way to enable this "after the fact"?

I do already have the .htaccess code in place, from another install of Vanilla that is doing Friendly URL's correctly.


  • You should already have a config.php located in the /conf/ directory, which is created when you first install Vanilla. Changes to config-default.php won't result in changes to the actual forum configuration, as far as I'm aware.
  • Thanks for the response!

    Ah yeah, my FTP client must have been caching that directory. It's there, and I changed the setting, and it works.... kinda.

    Last thing that seems weird is this:

    Should in between those slashes be the "friendly" stuff?
  • It should be the thread title. I'm not sure what's going wrong, there. Sorry. :(
Sign In or Register to comment.