Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Alternative Webservers

edited September 2010 in Vanilla 2.0 - 2.8
Apache is now a requirement of vanilla, differing from 1.x, is there really a specific reason why? I could understand if mod_rewrite was required, though users should be able to do that on their own in other web servers.
It would be nice to be able to upgrade to the current version, but changing web servers isn't really something I'm ready to do.

Comments

  • Options
    I'm running Vanilla 2 on Lighttpd. It works fine.

    The only problem I have is that I can't use friendly URLs because I haven't yet come up with some rewrite rules that 100% work like the .htaccess rules included with Vanilla 2. There were some bugs with 2.0.3 that were making the invalid assumption that everyone was using friendly URLs, but these have been resolved with 2.0.6.

    There are some plugins that make the same bad assumptions, but they are also slowly being fixed and they are generally easy to fix yourself once you understand the nature of the problem.

    So I'd say to throw up Vanilla 2 on a different path and try it out with your web server. Chances are good that it will work just fine.

Sign In or Register to comment.