Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

"bonk" message while trying to activate any new theme

edited September 2010 in Vanilla 2.0 - 2.8
Hi everyone.
I try to use the MEGA theme, but I always get the "Bonk" error message.
It does not only happend with MEGA theme, but also with any theme I tried (MEGA theme, rounder, old and minalla yellow).

While I navigate through dashboard, I dont get any error message and it looks like it goes well (exept that I have to do a manual page refresh to see "apply or discard" button if I preview the them).
So I apply the theme, and when I come back to the main page where are my discussions are listed, here is a "Bonk" message.

I already tried the fix that say to put an empty en-CA.php in conf directory with chmod 777, but nothing change, "Bonk" still here.

Any help will be very appreciate.

Using the latest vanillaforum 2.0.6 and a very fresh just downloaded of any of the theme I used (tried to use). I also made a full fresh re-install of vanillaforum, fresh database.


  • Options
    I am far from an expert on all this but I had the same problem and I found that I had deleted a folder in the cache file called "smarty" when I was doing the upgrade from 2.0.3 to 2.0.6. When I put that folder from a backup back into the cache folder of 2.0.6 everything started to work again, including the MEGA theme and all the other themes where I also got the "bonk". Do a search on this forum, there is a way to edit the forum software so that is shows the error message instead of showing the bonk. Having the error message was the way I finally figured out what was going on. I too had changed the permissions to 777 and the empty en-CA edit and it didn't make a difference. The "smarty" folder fixed it.
  • Options
    I checked if the smarty folder is in the cache directory. And it is already there.
    I saw this code to put in the config.php file, but it's look like vanilla rewritte it without letting me a chance to see the error message. It just say "Bonk".
  • Options
    Regarding getting error report to work, you have to comment out the old bonk line. I had same problem. See here:
  • Options
    Ok, it's work now.
    Dan you definitly save my day.
    The error was a missed "Smarty\compile" directory. I dont know if there is a need or not, but just in case, I chmod 777 both.
    Now it goes round just fine. Again, THANK YOU :)
  • Options
    Just wanted to report that I had this exact problem. The only theme that worked on my system was the default theme.

    However, when I switched the cache\Smarty permissions to '777' (they were 775) and the cache\Smarty\compile directory to '777' the other themes started working.

    Thanks for the tips guys.
  • Options

    I just had the same issue. Turns out Smarty was trying to write to /cache/ but the folder that was there was /cache/

    The thing is - I hadn't changed anything and this was working before. The only think I can think is that my server company upgraded PHP and something changed.

    Any ideas?

  • Options

    smarty write .ini files to the cache. e.g.


    /cache/ is the folder - you say it is trying to write a file called

    seems odd.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    There's really two things you need to know about this conversation. First, you need to get into your vanilla/cache folder. Second, you'll have to add a Smarty folder and a compile folder within Smarty. Permissions must be set as 777.

    Props to Left Brain for his specific instructions.

Sign In or Register to comment.