Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

What happened to the Minify plugin ?

edited September 2010 in Vanilla 2.0 - 2.8
After upgrading vanilla 2 to its latest version, i noticed the plugin Minify wasn't doing its job anymore. (ie : combining all js files into one minified file, same for css)

Also I searched for Minify in the Addons directory and couldn't find it.
Is the useful plugin "Minify" dead?


  • i think minify is distributed with the main vanilla download. i don't remember seeing it in the addons directory.

    did you disable and re-enable it? did you empty the cache?
  • edited September 2010
    @ithcy, thanks for the anwser, but it's still not working.
    I tried re-enable, empty-cache, and even reinstall.

    among the many scripts called in the head, i have this one:
    <script src="/forum/plugins/Minify/min/?b=forum&f=&v=2.0.9" type="text/javascript"></script>
    which appears to be a "HTTP/1.0 400 Bad Request"

    same for the stylesheet:
    <link rel="stylesheet" type="text/css" href="/forum/plugins/Minify/min/?b=forum&f=&v=2.0.9" media="screen" />
    ps: you're right, Minify is included in the main download of Vanilla
  • Ha! I just looked at my own forum and I've got the same problem and I didn't even realize it. This definitely looks like a bug. I'm trying to track it down now.

  • Yes, there is a problem here. If you look at the top of the scripts in the head you will see <script src="/forum/plugins/Minify/min/?b=forum&g=globaljs&v=2.0.9" type="text/javascript"></script>

    which returns jquery and a bunch of other js files. But those files are also included separately as scripts in the head. So in effect Minify is doing the opposite of what it's supposed to do, in that every global js file is being included twice.

    Can we get some love in here? @Tim @Todd?
  • edited September 2010
    exactly here is what ySlow tells me:

    minify disabled: 13 JavaScript File 215.8K
    minify enabled: 14 JavaScript File 248.6K

    Please someone help fix this.

    ps: i planning to release my forum next week and it has to be mobile friendly so minify is a must have
  • Ha! I just looked at my own forum and I've got the same problem and I didn't even realize it. This definitely looks like a bug. I'm trying to track it down now.

  • Hello,
    any news for this minify issue?
    @ithcy or maybe @Mark
  • @TiGR, I think this is not the same bug here.
    i tried "cutting basepath" from $Href, nothing changed
  • Somehow minify works well with this fix on my server with latest vanilla (2.0.11).
  • actually you're right, this is a path issue.
    your fix didn't worked for me, but removing vanilla folder from $Href works:
    $Href = str_replace('/vanilla', '', $Href);
  • @TiGR that patch you linked to is working well for me with Thank you
  • Not sure why this addon was removed.. but the one comes with the official download page failed to minify "!important"

  • You should not rely on minifiers, for javascript, except as part of a build process. It is a flawed technique, which is liable to fail.

    grep is your friend.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @vorapoap said:
    Not sure why this addon was removed..

    The cure was worse than the disease ....

Sign In or Register to comment.