Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

ProxyConnect on WordPress 3.0.1

dan39dan39 New
edited February 2011 in Vanilla 2.0 - 2.8
I'm having trouble getting the WordPress Integration manager to work with WordPress 3.0.1 and ProxyConnect 1.8 and Vanilla 2.0.9.

I installed the Vanilla ProxyConnect for WP3 plugin (ver. 1.2.0) into WordPress and activated it, and then I tried to set up the WordPress Integration manager, and all I get is the following cryptic error:

Could not set Challenge key on remote. Reason was: challenge Hmm... Not sure exactly what that means.

Next, I decide to copy the Vanilla Cookie Domain from the Vanilla Authenticate page to the WordPress Plugin page, and try again. This time it asks me what the URL is for my WP blog. So, I type in "" and now I get an error that says:

Unable to contact remote plugin. Perhaps your blog URL was incorrect?
But, the URL is correct, and the HTTP Response Headers on my blog even say:

X-ProxyConnect-Enabled: yes

So, I choose manual configuration and I copy over the URLs. (Every time I set the URLs, the Authenticate URL and then come back to the Authentication settings page, the Authenticate URL is blank every time. But the Authenticate URL is set in conf.php so I know it's received it. It just doesn't want to show it on the page.)

Unfortunately, once I set it all up every new user becomes the Admin user each time they sign in for the first time. No new accounts are created. This had all been working fine until I upgraded WP/ProxyConnect/Vanilla to their latest versions.

I've deleted all of my cache files, deleted my cookies and browser cache, wiped all of the Vanilla database tables clean and deleted my conf.php to re-install Vanilla from scratch. Every time I try another test user with a different email address, every new user becomes the original admin user.



  • Options
    The latest release of ProxyConnect (1.8) or at least the combination of vanilla 2.0.9 and ProxyConnect 1.8 in particular seems to be a tad flawed. You might also have a look at this discussion:

    I 've got a notion we will have to wait for the next release to get these issues fixed.
  • Options
    RaizeRaize vancouver ✭✭
    2.06 + 1.8 should work fine
  • Options
    Heh... 1.8 says it requires 2.0.7. You could see how confusing that might be for someone else who might download Vanilla for the first time to test it out!
  • Options
    I have just installed Wordpress 3.1 RC1 + Vanilla 2.0.16 (inside a vanilla subfolder) + ProxyConnect Plugin 1.8.4. on local development machine.

    Now I am trying to configure the ProxyConnect authenticator but when I specify the blog url as http://localhost/wp/ it gives the error:

    Unable to contact remote plugin. Perhaps your blog URL was incorrect?

    Any idea for a solution?

    If you need more info I will be happy to help
  • Options
    @Drake I'm having the same as you. Did you get the problem sorted out and if so would you mind sharing how you did it?
  • Options

    I didn't solve the problem yet. Unfortunately I am a bit under pressure, and don't have a lot of time to work at this project. If I have news, I will update.
  • Options
    LOL, I'm having a very similar problem... and also am working on a tight deadlined project... If I figure anything out, will also post here.
  • Options
    edited February 2011
    My wordpress doesnt show the plugin at wordpress plugin activate section. [I am wordpress advance user (developer)]
  • Options
    Check to make sure you have satisfied all of the server requirements for Vanilla. That's what fixed it for me.
  • Options
    I noticed a couple things.

    When Wordpress is installed under a folder like /wp/ and the site url is at / you have to double check the authenticate URL. I had it at /wp/?VanillaCheck=blahblah and that didn't work. Needed to be at /. You can easily test this by just pointing your browser at the authenticate URL. You should see a row of values.

    Also, double check that the cookie domain is actually being set. I noticed that I was setting the cookie domain in the vanilla forums admin, but it wasn't actually being written to the config.php. Once I fixed those issues, things seem to be running much better now.
  • Options
    Thanks for the answer. I am trying to install proxyconnect-plugin-1.8.4 on Version but no luck on vanilla as well. I tried several things including I extracted the zip file inside plugin folder of vanilla but the plugin is never shown on vanilla plugin dashboard. So till now no success of installing plugin neither in wordpress nor in vanilla.

    In both of the places plugin doesnt show on dashboard even after uploading plugin inside respective plugin directory.
Sign In or Register to comment.