Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Markdown addon only enabled in comments

edited September 2010 in Vanilla 2.0 - 2.8
I've tried installing the Markdown addon on my local build (latest version of everything) and it is only working in comments. The first post of every discussion never has Markdown applied to it.

I think this is a bug, but I'm willing to believe it's deliberate.

I'm a pretty good PHP programmer but I'm totally unfamiliar with Vanilla or its plugin architecture. Could someone tell me the best way of enabling Markdown on the first post, please?
Tagged:

Comments

  • Markdown seems to be included in Vanilla 2 by default, so we didn't even use a plugin to enable it. We just changed the input formatter in conf/config.php with a line like so:
    $Configuration['Garden']['InputFormatter'] = 'Markdown';
  • Thank you. That worked :)

    One wonders, though, why there is a plugin that is specifically marked as being for Vanilla 2 that reimplements out-of-the-box functionality, and why there isn't an admin option to enable Markdown =/
  • No problem!

    Yeah, I too wonder about both those things... perhaps at the time of this plugin's creation, there was no Markdown in Vanilla 2?

    But yes, it would be nice to be able to choose the input formatter from the UI. Perhaps the developers don't feel the input formatter selection is 'stable'.

    I do see that every post has meta-data on its indicating its input format, so perhaps the developers eventually want to let post authors choose whichever input formatter they want?
  • Is there a way to use two input formatters in Vanilla 2? Is that even a hypothetical possibility? (I'm willing to write a plugin)

    Ideally, I'd like to use Markdown with an html fallback.
    matt
Sign In or Register to comment.