Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.


cdavidcdavid New
edited September 2010 in Vanilla 2.0 - 2.8
Dear all,

I would be interested to know why RewriteURL-s don't work on my website and if you have any idea how to make it work.

ServerAdmin me ServerName DocumentRoot /var/www/planetbox <Directory /var/www/planetbox> AllowOverride All </Directory> RewriteLog "/var/www/planetbox/rewrite.log" Alias /icons/ "/usr/share/apache2/icons/" <Directory "/usr/share/apache2/icons"> Options Indexes MultiViews AllowOverride None Order allow,deny Allow from all </Directory>

Now, I have a default installation of Vanilla 2.0.6, so I have a .htaccess file in /var/www/planetbox :

RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ default.php/$1 [QSA,L]

In conf/config.php , I have:
$Configuration['Garden']['RewriteUrls'] = FALSE;

If I make it TRUE and go to , I get:
Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.
while the errorlog says:
[Thu Sep 23 21:32:58 2010] [error] [client] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer:

Any help is highly appreciated.


  • Does your apache have mod_rewrite enabled? You can make a phpinfo.php file that contains just <?php phpinfo(); ?> which will tell you.
  • If needed, I can show the entire blabla-s, but yes, it seems to be enabled.
    Loaded Modules [blabla] mod_rewrite [blabla]
  • you have a redirection loop. what does your /var/www/planetbox/rewrite.log say? you might have to turn up RewriteLogLevel in your apache config to get the full picture.
  • TimTim Operations Vanilla Staff
    That's an old / nonstandard htaccess file. Please use the one we provide, or insane problems like this will happen.

    # Original # If you modify this file then change the above line to: # Modified <IfModule mod_rewrite.c> RewriteEngine On # Certain hosts may require the following line. # If vanilla is in a subfolder then you need to specify it after the /. # (ex. You pur Vanilla in /forum so change the next line to: RewriteBase /forum) # RewriteBase / RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L] </IfModule>

    Vanilla Forums COO [GitHub, Twitter,]

  • Works like a charm.

    Thanks a lot!

  • Thanks @Tim worked great.

Sign In or Register to comment.